2

I downloaded ubuntu-filemanager-app opened the project in UbuntuSDK and want to run it in Emulator , but I get this error:

23:49:37: Running steps for project ubuntu-filemanager-app...
23:49:37: Starting: "/home/roman/.config/ubuntu-sdk/ubuntu-sdk-15.04-armhf/make" 
make: *** No targets specified and no makefile found.  Stop.
Command returned 2: schroot -c click-ubuntu-sdk-15.04-armhf-b7ba706d-013d-4a9d-9c5e-ff5a75748094 --run-session -- env DEB_HOST_ARCH_ENDIAN=little DEB_TARGET_ARCH_BITS=32 DEB_TARGET_GNU_CPU=arm DEB_TARGET_GNU_SYSTEM=linux-gnueabihf DEB_HOST_MULTIARCH=arm-linux-gnueabihf DEB_HOST_GNU_CPU=arm DEB_BUILD_GNU_SYSTEM=linux-gnu DEB_HOST_GNU_TYPE=arm-linux-gnueabihf DEB_BUILD_ARCH_ENDIAN=little DEB_HOST_ARCH=armhf DEB_TARGET_GNU_TYPE=arm-linux-gnueabihf DEB_BUILD_MULTIARCH=x86_64-linux-gnu DEB_HOST_ARCH_OS=linux DEB_BUILD_ARCH=amd64 DEB_BUILD_GNU_CPU=x86_64 DEB_TARGET_ARCH=armhf DEB_TARGET_ARCH_ENDIAN=little DEB_TARGET_MULTIARCH=arm-linux-gnueabihf DEB_HOST_ARCH_CPU=arm DEB_BUILD_GNU_TYPE=x86_64-linux-gnu DEB_BUILD_ARCH_OS=linux DEB_BUILD_ARCH_BITS=64 DEB_TARGET_ARCH_OS=linux DEB_BUILD_ARCH_CPU=amd64 DEB_HOST_GNU_SYSTEM=linux-gnueabihf DEB_TARGET_ARCH_CPU=arm DEB_HOST_ARCH_BITS=32 make
23:49:38: The process "/home/roman/.config/ubuntu-sdk/ubuntu-sdk-15.04-armhf/make" exited with code 2.
Error while building/deploying project ubuntu-filemanager-app (kit: UbuntuSDK for armhf (GCC ubuntu-sdk-15.04-vivid))
When executing step 'Ubuntu SDK Make'
23:49:38: Elapsed time: 00:01.
4
  • your emulator arch and the build target are the same arch? Jun 2 '15 at 6:08
  • yes, it's the same
    – user262898
    Jun 3 '15 at 17:58
  • i don't know what lead to this bug. i'm also have this bug recently... what solved it to me for now, it was to delete the build directory usually called build-project-UbuntuSDK_for_armhf_GCC_ubuntu_sdk_15_04_vivid-Default or something like that, and delete the *.user file, and open the project again. but it is seems to me very strange solution.... Jun 3 '15 at 20:01
  • did you have any error in the Cmake output? look at General Messages Jun 4 '15 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.