5

I have a problem with with my laptop, Toshiba Qosmio F60. Curently i am running dual boot with Win7, and Ubuntu 15.04. I used different distros and this is the first time i have this kind of problem.

After i click shutdown Ubuntu logo shows with those dots, first one changes color then the screen shuts down. NumLock and power light are still on, cpu fan goes to full speed, and it stays that way. Only way to shut it down completely is by force.

Restart works fine.

I run 64-bit version of stock ubuntu 15.04, with generic 4.0.4-040004 kernel version

EDIT: Since i haven't found solution to this problem, i reinstaled Linux Mint 17.1. Now the same problem is happening. Before Ubuntu i was running Manjaro, Mint, Fedora and Kali. Everything was working fine. I was thinking that my laptop could be a problem, but from Windows and live versions it shuts down fine.

  • I am also facing the same issue. and Force Shut Down may cause Data loss. – hims_3009 Jun 3 '15 at 5:51
  • Try removing the splash screen and look at the shutdown messages, If you see 'Reached target Shutdown' as the last message and if it hangs forever please read my answer below and let me know here in a comment as well as go to the bug link below and list your name in "This bug affects me" link there. – xtrchessreal Mar 8 '16 at 19:20
  • @dsumic : Im really not sure, but probably the 15.04 Ubuntu uses drivers that are too new, what means, you should probably try updating your BIOS, else probably only the Windows drivers work well with the old BIOS. Im having the same problem. – LMD Apr 25 '17 at 16:53
2

Having the same problem after upgrading to from 14.10 to 15.04 on my Dell Insperion 7537. Reboot works fine, shutdown acts like reboot.

this looks like it might be related Reboot after shutdown (Ubuntu 14.04 (also 12.04); Dell latitude E7440) I tried

sudo apt-get update && sudo apt-get install laptop-mode-tools

and changing GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=noirq" in /etc/default/grub

also tried the entries acpi=force apm=power_off there too. So far nothing has worked. will keep looking...

  • Any update @mrnohj ? I'm seeing the same problem on my Dell Inspiron 15 3551. – blong Jul 15 '16 at 13:58
1

First this may be bug #1464917:

If this affects you please go there and let them know by clicking "This affects me" link above the initial bug description.

After the shutdown or reboot has hanged with this message.

Reached target Shutdown

You may only see this if you have removed the splash screen. If the system has hanged for any reason you can use this method.

Try Sysrq

  1. Hold down the Alt and SysRq (Print Screen) keys.
  2. While holding those down, type the following keys in order, several seconds apart: REISUB
  3. Computer should reboot.

Once it reboots immediately try shutdown button again, it should shutdown properly. Please add your name to the "This Affects Me" button at launchpad bug link above if you think this is the same issue.

Update:

There has been a development as a work around to this bug. It seems to be related to the swap file usage/management. Adam (from the bug link above) points out that if you turn your swap off, wait for it to process, before you shutdown the hang never happens. When you are ready to shutdown your machine, open a terminal window and type;

sudo swapoff -a

Wait for the command to process and give your prompt back then you should be able to perform normal shutdown. This is working for many including me.

end update

You can also try the following after it hangs.

Try and login tty1 and reboot

  1. Press Ctrl+Alt+F1 or Ctrl+Alt+F2 or Ctrl+Alt+F3 ...
  2. Write your username (lowercase, the name of the user folder in /home) and hit Enter
  3. Write your password (nothing will appear) and hit Enter

If your password and username are correct, you are now logged in.

If that fails try Ctrl+Alt+Del a couple times at that point in the tty1 screen

You might see a message that states the machine is going to reboot and then it should do just that after a minute or so.

Its better than a hard boot - until its fixed.

In the bug notes it is reported that you can upgrade to Vivid-Proposed and it fixes the issue but some still see this after that upgrade. It might be worth a shot.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.