1

I went through all the existing posts on this but it didn't work. I tried doing

sudo dpkg --add-architecture armhf 

which didn't do anything. I also tried running a script i found on other questions and getting rid of the ppa but that didn't work either.... How do i fix this :( ? Or How do i get rid of this error?

I get the following error(Sorry i tried to post an image but it wouldn't let me b/c of my low reputation)

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/trusty-security/universe/binary-armhf/Packages  404  Not Found [IP: 2001:67c:1360:8c01::19 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/trusty-security/multiverse/binary-armhf/Packages  404  Not Found [IP: 2001:67c:1360:8c01::19 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.
4
  • 1
    I would avoid trying to put armhf packages on anything that isn't an armhf operating system... is there a specific reason you're trying ot do this?
    – Thomas Ward
    May 30, 2015 at 14:50
  • possible duplicate of How can I fix a 404 Error when using a PPA or updating my package lists?
    – JoKeR
    May 30, 2015 at 15:01
  • @Thomas W. I actually do not know why it's trying to install armhf. I think it's because currently i'm trying to install stuff to NVIDIA's jetson tk1 via ubuntu
    – JayC
    May 30, 2015 at 15:29
  • @JoKeR I ran the script banish404 but it got stuck and i had to force quit.
    – JayC
    May 30, 2015 at 15:30

1 Answer 1

0

In /etc/apt/sources.list, edit the lines which look like

deb http://archive.ubuntu.com/ubuntu/ trusty-security universe
deb http://archive.ubuntu.com/ubuntu/ trusty-security multiverse

so they look like this

deb [ arch=amd64,i386 ] http://archive.ubuntu.com/ubuntu/ trusty-security universe
deb [ arch=amd64,i386 ] http://archive.ubuntu.com/ubuntu/ trusty-security multiverse

then run sudo apt-get update again. The reason for your issue is that the repository you are trying to update from does not support the armhf architecture. You can test this yourself by navigating to http://archive.ubuntu.com/ubuntu/dists/trusty-security/universe in your web browser. You will see binary-amd64 and binary-i386 directories, but no binary-armhf directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.