0

Straight to the point , when i do a simple command such like sudo apt-get update this 2 lines always show up :

Ignoring unknown parameter "password level"
Ignoring unknown parameter "update encrypted"

Why does that happen ?

Edit: command testparm -s output

Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "null passwords" option is deprecated
Unknown parameter encountered: "password level"
Ignoring unknown parameter "password level"
Unknown parameter encountered: "update encrypted"
Ignoring unknown parameter "update encrypted"
WARNING: The "idmap uid" option is deprecated
WARNING: The "idmap gid" option is deprecated
Processing section "[homes]"
Processing section "[netlogon]"
Processing section "[profiles]"
Processing section "[printers]"
Processing section "[pdf-documents]"
Processing section "[pdf-printer]"
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_STANDALONE
[global]
    netbios name = LINUX
    server string = Samba file and print server
    interfaces = 127.0.0.1/8, 192.168.0.0/24
    bind interfaces only = Yes
    client schannel = No
    server schannel = No
    allow trusted domains = No
    obey pam restrictions = Yes
    guest account = smbguest
    passwd program = /usr/bin/passwd '%u'
    passwd chat = *New*password* %n\n *ReType*new*password* %n\n *passwd*changed*\n
    passwd chat timeout = 120
    username map = /etc/samba/smbusers
    username level = 6
    unix password sync = Yes
    log file = /var/log/samba/samba.log
    max log size = 1000
    name resolve order = wins, lmhosts, bcast
    client signing = No
    server signing = No
    client use spnego = No
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    printcap name = cups
    machine password timeout = 120
    add user script = /usr/sbin/useradd -d /dev/null -c 'Samba User Account' -s /dev/null '%u'
    delete user script = /usr/sbin/userdel '%u'
    add group script = /usr/sbin/groupadd '%g'
    delete group script = /usr/sbin/groupdel '%g'
    add user to group script = /usr/sbin/useradd -d /dev/null -c 'Samba User Account' -s /dev/null -g '%g' '%u'
    delete user from group script = /usr/sbin/userdel '%u' '%g'
    add machine script = /usr/sbin/useradd -d /dev/null -g sambamachines -c 'Samba Machine Account' -s /dev/null -M '%u'
    logon script = %G.bat
    logon path = \\%L\profiles\%u
    logon drive = m:
    logon home = \\%L\homes\%u
    os level = 33
    local master = No
    domain master = No
    dns proxy = No
    remote announce = 192.168.0.255
    remote browse sync = 192.168.0.255
    template shell = /dev/null
    winbind separator = @
    winbind cache time = 360
    winbind use default domain = Yes
    winbind trusted domains only = Yes
    winbind nested groups = No
    winbind nss info = no
    idmap config * : range = 16777216-33554431
    idmap config * : backend = tdb
    hosts allow = 127., 192.168.0.
    cups options = raw
    follow symlinks = No

[homes]
    comment = Home Directories
    path = /home
    valid users = %U
    read only = No
    locking = No
    strict locking = No

[netlogon]
    comment = Network Logon Service
    path = /var/lib/samba/netlogon
    locking = No
    strict locking = No

[profiles]
    comment = User Profiles
    path = /var/lib/samba/profiles
    read only = No
    create mask = 0600
    directory mask = 0700
    locking = No
    strict locking = No

[printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    print ok = Yes
    browseable = No
    locking = No
    strict locking = No

[pdf-documents]
    comment = Converted PDF Documents
    path = /var/lib/samba/pdf-documents
    admin users = %U
    read only = No
    guest ok = Yes
    locking = No
    strict locking = No

[pdf-printer]
    comment = PDF Printer Service
    path = /tmp
    guest ok = Yes
    printable = Yes
    print ok = Yes
    printing = bsd
    print command = /usr/bin/gadmin-samba-pdf %s %u
    lpq command = 
    use client driver = Yes
  • 1
    It may indicate an inconsistency in your SAMBA configuration (smb.conf file). Can you edit your question to include the output of command testparm -s please? – steeldriver May 30 '15 at 14:56
  • I notice too that , its seems slower when is reading my password , and that is a bit frustating. – UTUMUTU May 31 '15 at 10:02
  • I think your smb.conf file probably contains some deprecated (no longer supported) features - however I don't have enough experience with samba to suggest a solution. Let's hope someone else steps up. – steeldriver May 31 '15 at 13:32
  • Hmm thanks anyway ! Appreciated ! And really looking forward to a solution. – UTUMUTU Jun 2 '15 at 19:16
1

The problem is with the samba server. The better option is purge the samba server and manually remove the following files.

  1. /etc/samba/smb.conf
  2. /etc/samba/smbusers

Now restart the computer. It will work.

Note:

The reason for the error is the gadmin-samba. If you installed the gadmin-samba. It is advisable to purge gadmin-samba and manually remove the files related to gadmin.

All the best...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.