3

I've bought a Firefox OS mobile lately and I thought of flashing it with a new version of Gaia. According to MDN, I gotta set up ADB in my computer. I've done all that. But, over the last few hours, I'm having a major trouble connecting my device to my computer. In order to make-reset Gaia, I need to have connected to my device.

I ran lsusb, and I've found this as my device

Bus 002 Device 043: ID 1782:5d24 Spreadtrum Communications Inc.

So, I updated my 50-android.rules in /etc/udev/rules.d with the following information:

SUBSYSTEM=="usb", ATTR{idVendor}=="1782", ATTR{idProduct}=="5d24", MODE="0666", GROUP="plugdev", OWNER="wafflespeanut"

I also tried the methods suggested by this answer & this answer, which didn't make a difference :/

Every time I made a reasonable change, I rebooted my system. For other minor changes, I just pull the cable, logout/login and try connecting it again.

But, despite of whatever I do, whenever I run adb devices (along with udev restart, kill-server, start-server), I get nothing other than this default string.

List of devices attached

... which doesn't encourage.

So, is there anything I might've overlooked, or any ways at all to connect my mobile? Can you please help me out?

  • In my android-rules I only had to specify subsystem, the idvendor attr, mode, and group to get my tablet to connect to adb. Maybe try removing the other entries? Just a guess though. – Organic Marble May 30 '15 at 13:37
  • @OrganicMarble: Yeah, that's what I did at first. I added the other entries only when I found that the conventional ones had failed to work. – Waffle's Crazy Peanut May 30 '15 at 14:05
  • What version of adb are you running? – Organic Marble May 30 '15 at 14:10
  • @OrganicMarble: apt says that I'm running the latest version (4.2.2, I guess). – Waffle's Crazy Peanut May 30 '15 at 14:13
  • 1
    I had to go install 1.0.32 for some reason. I don't know if that is worth the trouble for you though. – Organic Marble May 30 '15 at 14:26
1

Perhaps try installing version 1.0.32? I may have had to do that to get it to work. But it's been quite a while.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.