3

i can run my wifi card (rtl8188eu) in ap mode in windows by using Realtek Wireless LAN Utility or Connectify.. But When i tried in ubuntu i got an error saying..

(32) Access Point (AP) mode is not supported by this device

How to fix this?

UPDATE: How did i try to set up an ap..

I used Network manager to create an wifi infrastructure network "Wi-Fi connection 1" and change the field mode=infrastructure to mode=ap in file /etc/NetworkManager/system-connections/Wi-Fi connection 1. and tried connecting to that network via connect to hidden network.

Edit: i just need to share my Wired Internet to other wifi deviecs through my wifi card.. not to connectify...

  • Please edit your question and describe what you did to setup AP. It should support it. – Pilot6 May 30 '15 at 11:04
  • @Pilot6.... edited – Sijin Krishnan May 30 '15 at 12:53
  • @Pilot6.. It is not... i dont need to run ap and get Internet from wifi simultaneously.. i just need to run my wifi card as ap alone.. and share my wired connection.. – Sijin Krishnan May 30 '15 at 12:57
  • But still read the answer. It gives directions how to setup AP. And also I met that realtek needs a custom hostapd. Anyway you won't set it in NM. – Pilot6 May 30 '15 at 12:59
2

It is possible.

I only know the method with hostapd to create an AP.

And to use hostapd with rtl8188, you need to use a patched version of hostapd. There are several version floating around. Look for rtl8188 and raspbian and hostapd in your favorite search engine.

For example here or here

But extra step is needed to make the bridge to share internet connection.

To ease things, I recommend to use create_ap that will do it in one step. See https://github.com/oblique/create_ap

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.