2

How to enable Intel_pstate in Ubuntu 15.04?

4

In 15.04 it's enabled by default thanks to @solsTiCe informative notes. you could check that yourself

if grep -i pstate /boot/config-$(uname -r) says yes then it's so.


To enable intel_pstate in Ubuntu 14.04 , edit the /etc/default/grub configuration file with a text editor as root

gksu gedit /etc/default/grub

And for "GRUB_CMDLINE_LINUX_DEFAULT=" , add "intel_pstate=enable", like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_pstate=enable"

Save the file and update Grub:

sudo update-grub

Restart your system and to check if intel_pstate is enabled, run the following command:

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver

The command above should return "intel_pstate".

source and more information

  • 1
    There is no need to set boot parameters. It is enabled by default. – Pilot6 May 30 '15 at 9:06
  • intel_pstate=enable is enabled by default? – Maythux May 30 '15 at 9:08
  • 1
    At least in Ubuntu 3.19 kernel cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver gives intel_pstate without any boot parameters. – Pilot6 May 30 '15 at 9:09
  • cat: /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver: No such file or directory This is my output – Maythux May 30 '15 at 9:10
  • 1
    "Starting with kernel 3.9, the new pstate power scaling driver is used automatically for modern Intel CPUs instead of the other drivers below." Source: Arch wiki – solsTiCe May 30 '15 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.