1

So, I've had Ubuntu for a good 6 months on my HP Chromebook 14. I downloaded and began playing Minecraft immediately with no problem. Then, today I go onto my laptop and open up Ubuntu. I double click my Minecraft folder and it opens up the .jar like a folder. Its marked as being allowed to execute as a program. I didn't change anything, but I've been looking on forums and haven't found this happening to anyone else. I've re-installed Minecraft multiple times,tried manually opening it from the terminal and everything but nothing has worked. If I need to re-install Ubuntu I will, but if this is fixable please like me know!

1

Follow these steps and your problems are gone.


Install Oracle Java 8

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer

and then

sudo apt-get install oracle-java8-set-default

Use the minecraft-installer:

sudo add-apt-repository ppa:minecraft-installer-peeps/minecraft-installer
sudo apt-get update
sudo apt-get install minecraft-installer

Once installed, run Minecraft from the menu / Dash, login with your Minecraft account and the installation should start automatically.

Source

0

Try reinstalling the openjdk package.

  1. Run sudo apt-get remove openjdk-7-jre

    If you don't have openjdk then skip to the last step

  2. NOTE - If you have a different version replace the 7 with the version number for your version
  3. Run sudo apt-get install openjdk-7-jre
That should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.