I can only get my trackpad to work by shutting down, removing the battery and holding down the power button for 15 seconds. If I do a normal reboot the trackpad no longer works, buttons included.

xinput list gives this output

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Synaptics TouchPad                   id=11   [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)    id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ HP Truevision HD                          id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ HP Wireless hotkeys                       id=12   [slave  keyboard (3)]
    ↳ HP WMI hotkeys                            id=13   [slave  keyboard (3)]

But on restart the PS/2 Synaptics Touchpad dissapears.

Also in System Settings the mouse/touchpad settings has nothing about the touchpad at all.

I have downloaded Ubuntu 14.10 and 15.04 and the touchpad does not work in either running as a live session.

This seems to be a common problem but I have not been able to find any help other than the hard reset option which is very time consuming.

Thank you

UPDATE As per suggested below installing the latest kernel fixed the touchpad but broke all internet connectivity. Upon installing extras connectivity returned but the touchpad is gone again. Any help?

  • Have tried to install one of the new kernel images ? For instance sudo apt-get install linux-image-3.19.0-18-generic
    – Harris
    May 30, 2015 at 1:53
  • Installing the new kernel fixed the mouse but i have lost all internet. I can't connect with wireless or a cable
    – Evan
    May 30, 2015 at 5:07
  • You need to install also the extra packages. sudo apt-get install linux-image-extra-3.19.0-18-generic linux-headers-3.19.0-18-generic. I thought they would be automatically added to the installation.
    – Harris
    May 30, 2015 at 10:53
  • Thanks Harris, ironically installing the extras enabled the internet again but disabled the touchpad so it is back to square one
    – Evan
    May 30, 2015 at 23:44

1 Answer 1


It's not a definitve solution, but it works whenever this happens:

sudo modprobe -r psmouse; sleep 2; sudo modprobe psmouse

This trick works for me I saw it in this answer: Kubuntu 12.04 - Touchpad and keyboard stopped working at random

  • Thank you, I tried the command you suggested and it did not change anything
    – Evan
    May 30, 2015 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.