0

I have been working on making a program (jekyll-helper) using Quickly and a while ago I worked on adding some content to the default help pages. I tested out open the help pages in the program while running the program through the quickly run command, and the help pages worked fine.

However, when I made a package for the program using the quickly package command, installed the package, and ran the installed version of the program the help pages would not work properly. Whenever I would open the help pages via the menu option Help > Contents, the following error would pop up in place of the help pages:

Document Not Found

The URI ‘ghelp:jekyll-helper’ does not point to a valid page.

Unfortunately I do not know when the issue began, as I only realized that the issue existed when I ran the installed version of the program, which was a bit of time after I had finished working on the help pages.

I did some Google searching and found a few similar issues that people had, however none of them had the same exact issue as I had.

I found this question on Ask Ubuntu that seemed to be related, Problems compiling with Quickly. That person had a similar issue, and they were able to get an error message related to the issue by running quickly package --verbose --extras. So I tried running that command and the package was able to build, however I got several error messages. I put up a copy of the terminal output here: http://pastie.org/10214514.

The person who wrote that issue figured out that it was caused by a new line being in the long description on the program. However, I checked my program's information in the DistUtilsExtra.auto.setup section of the setup.py file and there was no newline in the long description. Also their error message was somewhat different from the corresponding one I got. Thus the issue I am having did not likely have the same cause as the other person's issue.

I also found this somewhat related issue, Quickly gives warnings on packageing, not recognizing setup.py~, however that issue appears to be somewhat different from the issue I have been having. Also that issue was caused by automatic backup files created by Gedit, however I am using Atom to edit the source, which is not making such backup files.

The source code of the program is here: https://github.com/ExcaliburZero/jekyll-helper

How can this problem be fixed, and what is causing it?

0

After doing some research online, I noticed that help pages for programs are generally located using URIs such as help:ubuntu-help/index. I compared this to the URI my program was calling ghelp:jekyll-helper and noticed that my program for some reason put a "g" in front of "help".

I tried running yelp help:jekyll-helper in the terminal and it brought up the correct help files for my program. Thus the help files were being packaged, they just weren't being called properly.

So I looked for all instances of "ghelp" in my program and found two. One in jekyll_helper_lib/PreferencesDialog.py and another in jekyll_helper_lib/Window.py. I changed the instances of "ghelp" in each to "help" and re-packaged the program with quickly package --verbose --extras (though I still got a few warning messages). I installed the new package and ran the program and the help pages were then working.

So it looks like the call to the help pages for some reason had a "g" character in the URI that was looked up, which was preventing it from finding the help pages, whose correct URI did not include a "g" at the beginning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.