1

My USB 3.0 drives turn on after I turn them off in the Disks utility.

I've disabled auto-mounting via org.gnome.desktop.media-handling.automount. This worked as expected but doesn't help with my power on/off problem.

This only seems to happen when I use dd to write a disk image. Here's my workflow:

  1. Insert a USB drive from step 6
  2. Write USB drive using sudo dd if=someFile of=/dev/sdb bs=8M oflag=sync && sync
  3. Power down USB drive in "Disks" GUI. The drive disappears from the Devices list
  4. Wait a second. The drive reappears in the Devices list.
  5. Repeat (3). The drive continues to reappear.
  6. Remove drive from PC anyway.

I'd like to cut out steps 4 and 5. Why is the device being re-enabled?

I'm using 14.04.

  • hey OP, I didn't notice your post before, but I'm having the exact same issue – wjandrea May 30 '15 at 2:44
  • try to turn off with hdparam – totti May 30 '15 at 4:26
0

Did you try some other dd/usb-port/usb-cable ?

I had the same problem with my old DD. It was not getting enough power from my usb cable. It connected without problem and disconnected when I tried to use it. Maybe you have the same problem.

|improve this answer|||||
  • OP's issue is that the drive reconnects, not that it disconnects. – wjandrea May 30 '15 at 2:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.