2

I have installed redshift 1.10 and created its config file in

~/.config/redshift.conf

as shown in http://jonls.dk/redshift/, but when I execute redshift I get a:

No adjustment method 'randr'

So I list the methods with:

redshift -m list

and dummy is the only method listed.

so how I do install or configure the other adjustment methods?

  • Is there are reason why you're not using the version from the repository? Worked for me out of the box. – Benjamin Maurer May 29 '15 at 21:39
  • What hardware do you have and what video driver are you using ? "Your graphics driver and X server needs to either support at least RANDR version 1.3 or the VidMode extension" – Panther May 29 '15 at 22:01
  • i am using a geforce 210 with the default ubuntu trusty driver nouveau. @bodhi.zazen – Ivanyosan May 29 '15 at 22:48
  • can you post the output of xrandr =) – Panther May 30 '15 at 0:40
  • i have uploaded the xrandr output - @bodhi.zazen – Ivanyosan May 31 '15 at 20:35
3

First you have to download the .zip version of redshift from:

https://github.com/jonls/redshift

Then you have to install the dependencies:

autotools, gettext
intltool, libtool
libdrm (Optional, for DRM support)
libxcb, libxcb-randr (Optional, for RandR support)
libX11, libXxf86vm (Optional, for VidMode support)
geoclue (Optional, for geoclue support)
python3, pygobject, pyxdg (Optional, for GUI support)
appindicator (Optional, for Ubuntu-style GUI status icon)

as mentioned here

And now you do the installation:

    sudo apt-get install build-essential libxcb-randr0-dev
   ./bootstrap
   ./configure --enable-randr --prefix=$HOME/redshift/root \
       --with-systemduserunitdir=$HOME/.config/systemd/user
    make
    make install

and now:

$HOME/redshift/root/bin/redshift-gtk

I am in Colombia so the the config file I use is: (lat:lon from Colombia)

; Global settings for redshift
[redshift]
; Set the day and night screen temperatures
temp-day=6500
temp-night=4500

; Enable/Disable a smooth transition between day and night
; 0 will cause a direct change from day to night screen temperature.
; 1 will gradually increase or decrease the screen temperature
transition=1

; Set the screen brightness. Default is 1.0
;brightness=1.0
; It is also possible to use different settings for day and night since version 1.8.
brightness-day=1.0
brightness-night=1.0
; Set the screen gamma (for all colors, or each color channel individually)
gamma=0.8
;gamma=0.8:0.7:0.8

; Set the location-provider: 'geoclue', 'gnome-clock', 'manual'
; type 'redshift -l list' to see possible values
; The location provider settings are in a different section.
;location-provider=geoclue

; Set the adjustment-method: 'randr', 'vidmode'
; type 'redshift -m list' to see all possible values
; 'randr' is the preferred method, 'vidmode' is an older API
; but works in some cases when 'randr' does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

; Configuration of the location-provider:
; type 'redshift -l PROVIDER:help' to see the settings
; ex: 'redshift -l manual:help'
[manual]
lat=4.610078
lon=-74.082336

; Configuration of the adjustment-method
; type 'redshift -m METHOD:help' to see the settings
; ex: 'redshift -m randr:help'
; In this example, randr is configured to adjust screen 1.
; Note that the numbering starts from 0, so this is actually the second screen.
[randr]
screen=0

And that solved my problem

  • -1 OP isn't asking how to install redshift but about video driver compatibility issues. – David Foerster Jun 2 '15 at 10:53
  • There you go! Undeleted, edited and visible! (oh, and upvoted!) – Fabby Jun 12 '15 at 18:59
  • For me this didn't work. – UpmostScarab Jul 21 '16 at 16:25
0

I have similar problem. I had Ubuntu 14.04 and nVidia Geforce 310M driver. redshift worked fine. Yesterday I have totally removed and installed a fresh Ubuntu 14.04.1 and the recommended graphic card driver by Ubuntu. Now redshift does not work. I tried lots of things. The only worked solution (not for redshift) is:

xrandr --current --output LVDS-0 --gamma 0.1:1.0:1.0

which changes display colour.

  • but that may only change brightness and not color temperature. @Mir Saman – Ivanyosan Jun 4 '15 at 1:29
0

You may have created a redshift.conf file. Edit that very file and at bottom change screen=1 to screen=0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.