1

I have the xfce indicator plugin in the system tray. When I click on speaker icon > sound settings...:

Nothing happens. This used to work. pavucontrol is not launching, any suggestions on how to fix?

Using Xubuntu 15.04.

1

Pulseaudio is not running :
Type pulseaudio in a terminal and see if pavucontrol is ok.

  • If yes , the problem is that pulseaudio is not starting automatically when session starts:
    then run these 2 command in a terminal :

    mkdir .pulse
    echo autospawn=yes > ~/.pulse/client.conf

    Restart session and test.

  • If no, something prevents pulseaudio to start:
    Copy and run this command in a terminal to reset pulseaudio config:
    rm -r ~/.config/pulse/* ; rm -r ~/.pulse*; ~/.config/pulse
    and reopen session.

    Test also this to reinstall pulseaudio :
    sudo apt-get install --reinstall pulseaudio

    If not ok, likely a program is using soundcard : run this command to display this program: sudo fuser -v /dev/snd/* . If you see "sound-dispatcher', remove it running sudo update-rc.d -f speech-dispatcher remove

  • I have this problem even though pulseaudio is running (using 14.10). pavucontrol runs fine from a terminal but doesn't seem to be hooked into the indicator plugin. Anything else I can try? – dmcc Sep 9 '15 at 3:31
0

This almost surely happens because the user's session is not Xubuntu. To find out what your desktop session is, type in a terminal:

$ echo $DESKTOP_SESSION

If the terminal does not reply with xubuntu (or ubuntustudio, for that matter) then pavucontrol will never launch when the user clicks on the Sound settings option in the sound indicator. This is because of the following line of code in service.vala:207 (function activate_desktop_settings), part of the indicator-sound deb package:

    var env = Environment.get_variable ("DESKTOP_SESSION");
    string cmd;
    if (env == "xubuntu" || env == "ubuntustudio")

Thus to solve this, you must ensure you log in to Xubuntu desktop on the lightdm screen.

To solve this, there are two aspects to consider. First you should ensure that lightdm's default session is set to xubuntu. To do this, edit the file /etc/lightdm/lightdm.conf with root privileges and assign the value xubuntu to the key user-session (if it isn't already so), as follows:

user-session=xubuntu

However, you most likely got into this snag because you previously logged in to a desktop session other than xubuntu. To fix this you will need to select the appropriate option from the list of sessions available on the lightdm login screen. Log out (or start your computer) and click on the fourth icon from the right in the top panel. Then select "Xubuntu session" from the menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.