0

I had set up a vlan in interfaces file. Later on, even after removing the entries and restarting network, the ifconfig command is displaying that interface. Even ifdown isnt taking it down. Ifdown throws error message that the interface isnt configured.

Even after multiple times of examination, I am seeing the same thing again. Wondering why it worked in the same way in the Oracle VM Virtual Box also. Even after commenting-out in the interfaces file, networking restart, networking stop / start, ifdown && ifup, even machine reboot also..!! Same experience..!! Could somebody please try this and explain..?

  • Edit your question and describe in more detail what you have done. – A.B. May 29 '15 at 6:56
  • Why you don't give feedback for your questions?! Why you just asked and go away?! You can have to reply and mark answers when it's valid... take a look askubuntu.com/tour – Maythux Jun 17 '15 at 10:07
0

Edit /etc/network/interfaces

sudo gedit /etc/network/interfaces

Remove the vlan entries

Now you have to restart the interface

sudo ifdown eth0 

you can ignore the error if it appears here then

sudo ifup etho 

Now check again ifconfig

If it still shows that entry you may need to make a system reboot.

  • Thanks, but except system reboot, everything that you have suggested was done. (See the qn.) But, reboot isnt easy. Its a live server. :( – kiran bbnl May 29 '15 at 9:11
  • Ok then what is the result of ifconfig now? – Maythux May 29 '15 at 9:12
  • It still shows 'eth1.508' as well as 'eth2.508'. But 'eth2.508' had been removed from interfaces file long before. Only 'eth1.508' is still there in interfaces file. I had restarted the networking service many times. Tried 'ifdown eth2.508' also. Not working.. :( – kiran bbnl May 29 '15 at 9:18
  • Any idea from the logs below....? < May 29 11:55:12 server ntpd[3185]: unable to create socket on eth1.508 (71) for fe80::20c:29ff:fe4e:534a#123 May 29 11:55:14 server ntpd[3185]: Listen normally on 72 eth1.508 fe80::20c:29ff:fe4e:534a UDP 123 May 29 13:54:15 server ntpd[3185]: Deleting interface #72 eth1.508, fe80::20c:29ff:fe4e:534a#123, interface stats: received=0, sent=0, dropped=0, active_time=7141 secs May 29 13:55:36 server ntpd[3185]: Listen normally on 76 eth1.508 fe80::20c:29ff:fe4e:534a UDP 123 > – kiran bbnl May 29 '15 at 10:32
  • kindly come up with a solution. This exists to be a high, no, top priority issue these days...... Please be kind enough....! – kiran bbnl Jun 7 '15 at 8:50
0

If anybody comes across this now, I hope this helps!

Unfortunately, in order to get the interface to go away, you will need to re-create a valid config; this could be as simple as

DEVICE=eth2.508
BOOTPROTO=none
VLAN=yes

Bring up the interface with

ifup eth2.508

If successful, you can then bring the interface back down

ifdown eth2.508

At this point, you should see the interface removed from ifconfig, and can safely move the config file from your network scripts folder.

The lesson to be learned from this is to bring down an interface before deleting it!

I also strongly recommend moving the configs to an archive directory instead of deleting them in case a situation arises that it becomes required/desired again. On my CentOS servers, I would do

cd /etc/sysconfig/network-scripts
mkdir if-archive
mv ./eth2.508 ./if-archive/eth2.508.20170621-01

You'll notice the filename has yyyymmdd-vv appended to it; the -vv is for if you have multiple configs from the same date, you can manually increment this to keep multiple copies. If you don't have a need, don't add it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.