0

I am new to ubuntu, and I cannot seem to solve this problem.

When I try running the command tar -xvf linux.hla.tar.gz, I get the error message

tar: linux.hla.tar.gz: Cannot open: No such file or directory tar: Error is not recoverable: exiting now.

I have copied it down to the desktop, but I can still not seem to figure it out.

I am trying to install hla for the book "The Art of assembly language" by Randall Hyde.

I also tried tar -xzvf filename.tar.gz, but it didn't work.

  • 1
    Are you sure you are in the same directory as the file? – Stephen May 29 '15 at 2:19
  • The file is gzipped too, perhaps you could try tar -xzvf linux.hla.tar.gz. – Marcos Silveira May 29 '15 at 2:19
  • I also tried tar -xzvf filenam.tar.gz, but it didn't work – Tootsky3 May 29 '15 at 2:22
1

It turns out I was in the wrong directory and I just never changed directories, courtesy of Stephen, who posted in the comments

  • And tar xvf ... is enough. You don't need z or something else. – A.B. May 29 '15 at 5:10
  • Thank you! I thought you needed the z, but that's one less step for my computer! – Tootsky3 May 29 '15 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.