0

When I try to upgrade Openfire from 3.8.2 to 3.10.0, it gives the following error.
I am using Ubuntu 12.04.

1. wget http://download.igniterealtime.org/openfire/openfire_3.10.0_all.deb
2. sudo dpkg -i openfire_3.10.0_all.deb
(Reading database ... 204041 files and directories currently installed.)
Preparing to replace openfire 3.10.0 (using openfire_3.10.0_all.deb) ...
testing JVM in /usr ...
Shutting down openfire
Stopped.
Unpacking replacement openfire ...
Setting up openfire (3.10.0) ...
update-rc.d: warning: /etc/init.d/openfire missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
Starting openfire
nohup: appending output to `nohup.out'


Processing triggers for ureadahead ...

I have Googled and came up with this link but still no solution.

0

The thread provided in link states this:

  • stop the running OpenFire: sudo /etc/init.d/openfire stop , if it doesn't stop then search and kill its process by sudo kill -9 PID

to get the PID

ps aux | grep openfire

the result would be something like:

maythux   3541  0.4  0.0 613892 18500 ?        Sl   09:17   0:00 blah blah blah

Here the PID is 3541, then to kill this process run the command

sudo kill -9 3541
  • delete all plugins (NOT their data directories): sudo rm /var/lib/openfire/plugins/*.jar
  • update the old OpenFire using dpkg with the following command:

    sudo dpkg -i openfire_3.10.0_all.deb
    
  • if it's not already running, start it again: sudo /etc/init.d/openfire start

  • After it runs and get into the admin interface try to re-install the plugins you had, the settings will be retained

  • go to Security Settings and make the checkmark at "Accept self-signed certificates. Server dialback over TLS is now available."

answer was quoted from here

| improve this answer | |
  • i tried this "etc/init.d/openfire stop Shutting down openfire Stopped." – kamlesh.bar May 28 '15 at 6:17
  • @kamlesh.bar check the edit – Maythux May 28 '15 at 6:19
  • Still same error no solution – kamlesh.bar May 28 '15 at 6:19
  • did you stop it correctly? – Maythux May 28 '15 at 6:22
  • yes it says openfire stopped – kamlesh.bar May 28 '15 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.