0

I realise that there are similar questions on this problem for Ubuntu, including a question that I asked myself, but I have the same problem with Kubuntu 15.04.

My Kubuntu system is set to a resolution of 1920 x 1080 through Display Configuration settings. On system start-up (or after logging out and logging in again), the 1920 x 1080 resolution is not applied and the login screen resolution is incorrectly set to the native screen resolution of 3840 x 2160, but changes back to the correct setting after logging in.

I was interested in why this seems to be occurring, and if there are any solutions that will apply the correct settings on system start-up and after log in. For reference, my laptop is a Lenovo Y50 UHD.

2
  • I really would LOVE the reputation points, but I don't think it would be right for me to take credit for someone else's ideas, unless of course I had improved upon them. I think this question has been asked and answered....askubuntu.com/questions/73804/wrong-login-screen-resolution – user175999 May 30 '15 at 5:48
  • I referenced it in the question I asked before but I don't think they apply to Kubuntu (and there were also some other problems that I mentioned in that post). Does Kubuntu use LightDM as the display manager? – amy May 30 '15 at 9:08
0
+100

The way I solved this on my laptop:

  1. Create a new xorg.conf file and copy it to /etc/X11

  2. Under Section "Monitor" add the following line

    Option "PreferredMode" "1920x1080"
    
  3. Under Section "Screen" in SubSection "Display" add the Modes entry below the Depth line as shown.

    Viewport   0 0
    Depth     24
    Modes "1920x1080"
    

These changes will make "1920x1080" the default resolution for login and session.

To generate the xorg.conf file you need to go to tty1 (Ctrl +ALT+F1) and after login stop the X server (sudo service lightdm stop) and issue sudo X -configure. Then copy the temporary xorg.conf.new file to /etc/X11/xorg.conf and reboot.

0

Kubuntu 15.04 doesn't have lightm for the login screen, instead the new sddm. It is still in the development phase actually. Look for issues here.

0

I had the same issue and found there were to patch this but without a real reason.

According to documentation of sddm:

_DisplayCommand_=
Path of script to execute when starting the display server. Default value is "/usr/share/sddm/scripts/Xsetup".

The obvious solution is therefore to add the xrandr command to /usr/share/sddm/scripts/Xsetup. This can be easily retrieve with ARandR.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.