11

I would like to set Thunar as my default file manager in 15.04. Now, I realize that this question is very similar to How to set Thunar as a default file manager?, but I have tried Kevin's answer, why I even tried rebooting after I completed his suggestion but still Nautilus is used as my default File Manager. I even tried the shell script, Midnight Commander and Manual solutions recommended on the Community Help Wiki. Not one changed Thunar to my default file manager.

I was curious as to whether exo could change my default file manager at all, say to dolphin (as I also saw this question and its answer) but that also failed. Something tells me that this issue affects not just me but other users too, specifically 15.04 users, as Ubuntuuser reported in the comments that he could not set dolphin as his default file manager via exo either.

If you would like to know how I am checking whether these file managers are set to default, well I open folders on my desktop by double-clicking them to see whether they're opened in these alternative file managers or not and as a second test I also try to save files in Chrome to see whether the file manager window that pops up is the one I want.

If relevant I am running Unity as my Desktop Environment.

13

None of the other solutions worked for me. It turns out my desktop manager uses gvfs and not xdg. Thus I had to configure the mimetype for gvfs.

See what's currently set:

gvfs-mime --query inode/directory

Set it to Thunar:

gvfs-mime --set inode/directory Thunar.desktop

And test it:

gvfs-open $HOME
2

I'm sorry that this is a bit late but I hope it is still helpful to you and others. I've never found the 'exo' method to work either and it was annoying to install an application for just this purpose so I looked for the manual method. The way to properly set this option (for the current local user) is to edit the file

~/.local/share/applications/mimeapps.list

and add this snippet to the bottom

inode/directory=Thunar.desktop

so that it looks like the one I am linking below.

I believe another way to set it is

xdg-mime default Thunar.desktop inode/directory

but I can't remember if it works exactly the same way as the method I posted above.

I'm not certain if you need to logout or not for this to take effect, but it's certainly far easier than using some script, replacing binaries, or other such hackery. The one thing that I don't know how to change is the file picker dialog. The setting is determined by GTK but there doesn't appear to be a way to configure it. I hope this helps. :)

(If after a while you decide you want the Unity quicklist for Thunar too, open up another question and I'll answer that also)

Default applications list

1

If Ubuntu is anything like Debian Raspbian, all you have to do is just create a folder on the desktop, right click it, open with, select Thunar, make sure "use this as default application for this type of file" is checked, and hit ok. If that doesn't work, I'm sorry I cant help you past that

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.