2

I've installed Ubuntu 15.04 on a new Lenovo Thinkpad S440. With 8 gig of RAM, an i7 and an SSD I expected Ubuntu to boot in a few seconds, instead it seems to be taking almost a minute.

I've read a couple of similar questions and people always ask to see the output dmesg, but when I take a look at my dmesg I'm not really sure what I should be looking out for. Here's the output in case anyone wants to take a look.

UPDATE: I've just spent some time restarting my computer and checking the time of each boot. It can vary from between 8 seconds to 73 seconds!

2

The number on the left is seconds (and microseconds) since boot. Look for big jumps.

  • Your USB startup probe (3-18) is taking a really long time. This might be worth investigating.
  • And USB again, (31-44) under udev is slow
  • Then there's a 4-second pause at 46.699188, after the USB touchscreen initialises.

Noticing a theme here? Something in your USB setup looks like it's nailing the USB performance. This could be bad Kernel drivers for your USB chipset or a bad device (I've had simple USB devices render a system unbootable until they were removed) or a combination of the two.

I'd start by removing all the USB devices and trying to boot. If it's speedy, add one device at a time until you find a trouble-maker. If it's always slow, start investigating your USB chipset.

It might also be worth creating a bootchart to see how concurrently your services are managing to start up. It could be that the USB is just a coincidence and something is using 100% CPU. A bootchart will show this.


Edit: just re-read the question and see this is a laptop and therefore the touchscreen is probably hard-wired in. If you have a BIOS option to disable it, use that.

  • 1
    But then he can't use touch screen. – dedunumax May 27 '15 at 12:36
  • Thanks, I've just taken a look in BIOS and there doesn't seem to be any setting that allows me to disable the touchscreen in there. Your answer does help me understand how to use dmesg to diagnose the problem myself though so I've marked this as correct. – jessenorton May 27 '15 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.