I have installed Ubuntu GNOME 14.04 with gnome shell version 3.12.In log-in screen there is three options : "System Default","Gnome Classic" & "Gnome". When I select "Gnome" there is no problem & I can use it flawlessly but if I select "Gnome Classic" it boots into a gray screen with a mouse pointer and nothing happened.So how can I open the "Gnome Classic".

PS: Here how to troubleshoot the Gnome Classic Session? is the same problem as of me.But there is no answer.

  • Did you try to rename temporarilly your ~/.gnome directory and restart your session? – Philippe Gachoud May 27 '15 at 8:12
  • No I have not.But how can I do that please explain. – Bodhoday Mukherjee May 27 '15 at 8:13

For me the following solution worked:

  1. Install the kernel


and the headers

linux-headers-3.15.0-031500rc2_3.15.0-031500rc2.201404201435_all.deb linux-headers-3.15.0-031500rc2-generic_3.15.0-031500rc2.201404201435_amd64.deb

then reboot.

  1. Install nvidia-331, bumblebee and primus

sudo apt-get install nvidia-331 bumblebee bumblebee-nvidia primus

  1. Edit the bumblebee.conf file

sudo gedit /etc/bumblebee/bumblebee.conf

line 22: Driver=nvidia line 55: KernelDriver=nvidia-331 line 58: LibraryPath=/usr/lib/nvidia-331:/usr/lib32/nvidia-331 line 61: XorgModulePath=/usr/lib/nvidia-331/xorg,/usr/lib/xorg/modules

save and reboot

From here


Try out

  1. ctr+alt+f1 and log in
  2. sudo service lightdm stop
  3. mv ~/.gnome ~/.gnome_backup or mv ~/.config ~/.config_backup
  4. sudo service lightdm start
  • I am using gdm instead of lightdm.Though I have tried the above commands.But nothing happens. – Bodhoday Mukherjee May 27 '15 at 12:32
  • did you try the same as above with ~/.config as askubuntu.com/questions/628468/… it solved a problem for me... – Philippe Gachoud May 28 '15 at 19:26
  • No.But today I have installed ubuntu 15.04 with gnome shell version 3.14.So there is no issue now. – Bodhoday Mukherjee May 28 '15 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.