0

I'm running Xubuntu 14.04 on an old dell tower I pulled out of my closet to use ruby on rails with.

I was attempting to install ruby and rails but none of the installs took. My system is updated and upgraded. I then tried to switch to ubuntu 15.04 but the terminal wouldn't allow for this either. I decided to change to ubuntu 15.04 through the software center but I couldn't find the software center. I tried to install it but the terminal out put the same as everything else, something like "can't find files".

I then realized after trying to search for the software center that it is on the drop down named as "\s\s\svb". When I try to run it I only get an alert stating "Failed to execute command "/usr/bin/software-center%u".

I have tried to download ubuntu 15.04 on my windows laptop and load it to a flash drive using unetbootin but It will not run on my tower. I can't upgrade desktops through the terminal, or apparently find or install any files. I can't access the software center either. I'm not very experienced with linux and I only want to learn ruby on rails which isn't something I am able to do very easily on windows. Any ideas or solutions would greatly appreciated.

  • What do you mean by "but the terminal wouldn't allow for this either"? Please edit your post to include the exact error messages you got. – Carl H May 27 '15 at 7:17
0

To install Ruby On Rails, use this command

sudo apt-get install rails

Source: Ubuntu Documentation for Ruby On Rails

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.