3

I've just installed Xubuntu 15.04 in my Dell laptop after using Ubuntu for over 2 years. I can't get the sound to work in my Samsung monitor, which is connected to the laptop through its HDMI port. It worked fine under Ubuntu and even during the live session with the Xubuntu CD, but it stopped working after I installed the OS and booted from the HDD.

Things I've already tried include:

  • fully update my system through apt-get;
  • install PulseAudio Volume Control and change the output device (the HDMI port was not listed there);
  • use speaker-test to activate HDMI sound (the HDMI sound output device is not listed, so it has no ID that I can use to call it);
  • use a proprietary graphics card driver (the Software & Updates application suggested NVIDIA 340.76, but after I rebooted, I couldn't get video to work and had to reinstall the entire OS);
  • run sudo alsa force-reload (nothing seemed to change).

Below is the relevant output for lspci and lspci -v, showing my graphics card (the monitor is connected through HDMI after all) and aplay -l, to show that the HDMI sound output device is not listed anywhere.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: ALC3234 Analog [ALC3234 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
$ lspci -v
3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/820M / GT 620M/625M/630M/720M] (rev a1)
  • If the hdmi port is not listed then maybe it's an alsa problem. Have you tried the following command sudo alsa force-reload – mchid May 27 '15 at 4:08
  • Also if you run lspci -v it will show you what (if any) kernel module (driver) is in use. – mchid May 27 '15 at 4:10
  • Finally, if using nvidia drivers, select the one from software center under edit > software sources > additional drivers and there should be a "recommended" version of nvidia there. – mchid May 27 '15 at 4:11
  • I just updated the question with the results for your suggestions. As for changing the driver, I initially chose the (proprietary, updated) version, not the (proprietary, tested) one, but since I broke everything the first time, I'm hesitant in trying this again. There is no (recommended) version. – Douglas De Rizzo Meneghetti May 27 '15 at 4:21
  • just for future reference, I believe recommended is usually the proprietary, tested version. – mchid May 27 '15 at 4:23
2

See the answers on this post:

HDMI sound option disappears when I install the latest updates to Ubuntu Vivid 15

Apparently it is a bug in the latest kernel. Revert to an earlier version or wait until next kernel update.

edit: this should probably have been a 'comment', not an 'answer'. Sorry.

  • You're right. The kernel was updated today from 3.19.0-18 to 3.19.0-20 and the problem is fixed. – Douglas De Rizzo Meneghetti Jun 11 '15 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.