Okay, so I purchased a usb wireless adapter for about 25 bucks in the hopes that it might work better than my on-board Broadcom one. When I type in the following command:


I get the following:

Bus 001 Device 002: ID 8087:8001 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 005: ID 0bda:5682 Realtek Semiconductor Corp. 
Bus 002 Device 004: ID 04f3:20d0 Elan Microelectronics Corp. 
Bus 002 Device 003: ID 0a5c:216f Broadcom Corp. 
Bus 002 Device 007: ID 20f4:648b TRENDnet TEW-648UBM 802.11n 150Mbps Micro Wireless N Adapter [Realtek RTL8188CUS]
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Now, the usb adapter is the TRENDnet(from Realtek) one, but it doesn't seem to work. It keeps trying to continually log-in to my wireless with no success. I was poking around and found some other related posts from years ago, which suggested to disable WEP, but that is already disabled by default.

What could be the problem? Any help would be appreciated.

  • Did it need a driver or did it get recognized as soon as you plugged it in? May 27, 2015 at 1:23
  • It does indeed recognize the dongle, and I surfed with it for a little bit, but then it just stopped working. It's a bit wonky. Maybe I have a defective device?
    – Ray
    May 27, 2015 at 3:23
  • Maybe. Did you try other ports and did you reboot? May 27, 2015 at 10:50
  • Wow! So far switching to the other USB port is surprisingly working! If it works for the rest of the day, I think this issue has been solved. I will check back in to report.
    – Ray
    May 27, 2015 at 20:00
  • Okay, I spoke too soon. Shortly after I posted this, it disconnected. No dice, folks!
    – Ray
    May 27, 2015 at 21:17

1 Answer 1


Your device uses the driver rtl8192cu. The built-in driver is known to be unstable and tricky to connect. With a working internet connection,please do:

sudo apt-get install linux-headers-generic build-essential dkms
git clone https://github.com/pvaret/rtl8192cu-fixes.git
sudo dkms add ./rtl8192cu-fixes
sudo dkms install 8192cu/1.10
sudo depmod -a
sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/


  • Did this, but it didn't work. Still had the same issue.
    – Ray
    May 27, 2015 at 19:59
  • Did you try a reboot? If it still doesn't work as expected, I suggest you start a new question and we'll troubleshoot the Broadcom.
    – chili555
    May 27, 2015 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.