9

I'm trying to get CUDA (although not sure exactly what it is) to work in Ubuntu for GPU rendering in the Blender 3D modelling program. On Windows 7 64-bit, it works flawlessly. In Ubuntu, I can't enable the GPU processing features in Blender. I'm assuming Nvidia's CUDA needs to be installed.

Can this be done? If so, can I get the details on how to do it? Thanks!

Running Ubuntu GNOME 15.04 x64 w/ GNOME 3.14, Nvidia GTX 660 and Nvidia proprietary drivers.

10

To install CUDA from the standard repositories do a:

sudo apt-get install nvidia-cuda-toolkit nvidia-modprobe

This will currently install V6.5 of CUDA. At the time of this writing V7.0 is the latest and can be had straight from the nVidia repositories. Read this warning before you head to the nVidia repositories.

  • 1
    Thanks for the suggestion. I did try to install that package by itself and see if that would fix it. However, it didn't enable the CUDA/GPU rendering capabilities in Blender, unfortunately. – Jesse Jul 31 '15 at 19:48
  • 1
    I edited your post to include the package "nvidia-modprobe" in the command. YES, it works! It needed nvidia-modprobe for Blender to read the GPU's. Thanks for the help! – Jesse Aug 18 '15 at 6:34
4

I was able to find a solution on Nvidia's website. They have a .deb package that you have to download and install on your system to enable the repository to install CUDA from Nvidia directly. Here's how I got it working:

  1. Go to https://developer.nvidia.com/cuda-downloads
  2. Choose the .deb file that corresponds to your Ubuntu version. (At the time, they didn't have a package for Ubuntu 15.04, so I chose the one for 14.10 instead. This did solve my problem, but I'm not sure if it will create any compatibility issues down the road. Doesn't seem like a terrible risk, but I wanted to make that known.)
  3. Go to your file browser, located the downloaded .deb package, and double-click (or single-click) to install the package via Ubuntu Software Center.
  4. Open a terminal
  5. Type: sudo apt-get update
  6. Type: sudo apt-get install cuda
  7. Wait for the packages to download and install, then restart your computer (the packages were over 900MB for me, so it took around 20 minutes to download with my connection)

After the reboot, Blender was able to use CUDA to initiate GPU rendering and baking. Problem solved!

  • The CUDA downloads page gives a choice between the "network installer" or the "local package installer". I used "network installer" and all went well. Following step 6, some downloads are served from your default aptitude server; while others come from developer.download.nvidia.com. – user643722 Aug 5 '15 at 12:43
  • ubuntu 15 reports unable to locate package cuda – Siddharth Nov 20 '15 at 19:18
  • @Siddharth, I'd encourage you to check the solution I marked above as "answering this question". This will resolve the issue of Nvidia and CUDA utilization. :) – Jesse Nov 21 '15 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.