So I was trying to install openfoam on ubuntu 14.04 and there are two problems I need your help with. One, a strange code appears everytime I run the terminal(I've attached a picture of it). Two, I cannot run openfoam, an error occurs, a picture of which is also attached. Please help, I am new to ubuntu. Problem 1 Problem 2

  • This refers to the second issue you were having (openfoam): <br /> It appears that a file is missing in the openfoam, specifically dealing with the file/folder controlDict and is unable to execute as a result. Have you tried redownloading openfoam or replacing the file/folder with a new copy? – wsme May 27 '15 at 0:29
  • Hello Chris, I haven't tried that. I wanted to know if this was a problem with the installation or a problem with ubuntu before I did anything. Would you suggest me to reinstall openFoam and this would solve it? – GramCracker May 27 '15 at 0:36
  • This seems like an issue with the installation. Try reinstalling openFoam and you should be able to run it with no problems after. – wsme May 27 '15 at 15:25

Neither of these suggestions may work for you, but here's what I would try first:

Regarding the first issue, there's a hidden file in your home folder called .bashrc. Open a terminal and type ls -a which means "list files -all of them" and you should see the file. The contents of this file are executed every time you open your terminal, and I suspect that the offending line may have inadvertently been appended to it.

Again from the command line, type gedit .bashrc to open the file in a text editor, then search (ctrl-f) for the word ELMER4.0. If it shows up, comment out the line it occurs on by preceeding it with a #. Save the file (ctrl-s), then close the terminal and re-open it again. The error should be gone.

For the second error, the first thing I would do is to type sudo apt-get -f install into the command line. This will list any unmet depedencies any currently installed packages may have. If anything is missing, you can attempt to install it directly with sudo apt-get install [package-name].

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.