0

I'm relatively new to Ubuntu, and I'm having some issues with my wireless internet.

When I boot up Ubuntu, it connects to the internet fine and I'm able to use it. But, sometimes after a while it randomly stops working (can't open new links or refresh current web pages). It says that I'm still connected. When I disconnect, it doesn't disconnect immediately, and when I try to reconnect it won't no matter how many times I try. The only way I can reconnect is to restart my computer, and I do not have access to Ethernet wire connection to try to bypass the issue.

I do not have this issue when I boot my computer into Windows 8.

I have tried deleting that wifi connection and adding it again (as suggested by one of these threads), but that did not help.

My output for the:

lspci -knn | grep Net -A2    

command in terminal is:

01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
Subsystem: Hewlett-Packard Company Device [103c:2231]
Kernel driver in use: rtl8723be

Any help would be greatly appreciated.

Thanks.

  • Please edit your question and add there output of lspci -knn | grep Net -A2 terminal command. – Pilot6 May 26 '15 at 23:10
  • Hi Pilot6, I have added that information. Thanks. – Canada709 May 29 '15 at 13:35
  • possible duplicate of rtl8723ae unstable on Ubuntu 14.04 – Pilot6 May 29 '15 at 14:44
  • This is a duplicate of another question askubuntu.com/questions/627903/… , but solution is same. – Pilot6 May 29 '15 at 15:10
  • I have tried that now, I'll comment back here in a day or two if it's working fine (to test it out). – Canada709 May 29 '15 at 23:32
0

I finally made a ppa with this driver. It can be installed by

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms

In this case you will not need to re-install after kernel updates.

  • Hi Pilot6, Sorry for the delay - the other solution (askubuntu.com/questions/627903/…) has been working well. I have now tried this new solution, I'll be back in 2-3 days to let you know if there are any issues. Thanks again! – Canada709 Jun 13 '15 at 22:34
  • @Canada709 It is the same driver. The difference is that you don't have to re-install it after kernel upgrades. I just re-packed to be more handy. – Pilot6 Jun 14 '15 at 8:29
  • Hi Pilot, Okay, sounds good. – Canada709 Jun 19 '15 at 17:39
  • Hi again, Yesterday I had the same issues come up again, so I'm going to update it and see what happens. But it may not be as permanent as expected or perhaps my computer has some other issue. Just thought I would let you know. – Canada709 Jul 8 '15 at 13:29
0

You need to install a better wireless driver. It can be done this way. Run in terminal these commands (one by one):

sudo apt-get install git build-essential
git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo make install

You will need to re-install it after each kernel upgrade.

I am working on dkms module.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.