I have a Lenovo G40-70 laptop, which comes with RTL8723be driver.

I'm using Ubuntu 14.04 LTS (with Kernel 3.16.0-38-generic), but this bug also occurs in 14.10 and 15.04.

Even with options rtl8723be fwlps=0 ips=0, the problem is not fixed yet. Wireless is unstable, lots of websites keeps loading forever and Ping command frequently shows data loss. It's very annoying. :(

BIOS version is the latest.

Blacklisting ideapad_laptop also doesn't work.

Sorry my english and thank you!


You tried an old solution. You need to install another driver. Run in terminal

sudo apt-get install git build-essential
git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
sudo make install

Then reboot.

You also can remove that file with options rtl8723be fwlps=0 ips=0.

Note You will have to re-install it after each kernel upgrade.

New option:

You can now use a ppa instead of manual compiling:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms linux-firmware

i've stubbed on the same problem.

On this network card there are two antenna connections, the manufacturers are using the second one. The unstable signal is due to your configuration is using the wrong one.

On this answer there is an deeper explanation. Chilli555 answer

He suggests the following command, but it leaves you with the prior problem with the energy management.

echo "options rtl8723be ant_sel=2"  >  /etc/modprobe.d/rtl8723be.conf

Change it to

echo "options rtl8723be fwlps=0 ips=0 ant_sel=2"  | sudo tee /etc/modprobe.d/rtl8723be.conf

I faced this issues regarding rtl8723be and this is my saved post please see if you're problem gets solved.


those who are suffering from severely low wifi signal on ‪#‎ubuntu‬ and having ‪#‎rtl8723be‬ wifi chipset on hp or any device can follow below instructions to solve the problem as it can turn a nightmare to sit next to router and still not getting full range on newly bought laptop.

i don't have a tech blog so feel free to share on your blog.


  1. Open Terminal and execute this command(needs git installed) if you don't have git installed just download the rtl8723be zip and extract and skip this.

    --> git clone https://github.com/lwfinger/rtlwifi_new

  2. --> sudo make

    1. --> sudo make install
    2. --> sudo modprobe -rv rtl8723be
    3. --> sudo modprobe -v rtl8723be ant_sel=2
    4. --> echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf

its because the ubuntu default kernal uses the wrong antenna for wifi.

SOURCE: ubuntuforums.com and several other sites.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.