0

This question already has an answer here:

I need help, I am very new to Ubuntu and am running 14.04 LTS. the problem was that my password login screen would prompt me twice for my password, I could not find a solution so I decided to remove my password login completely. I found a web page telling me how to remove it and I succeeded in doing so, but now it prompts me twice for my keyring password.. I have looked for a solution to this but no luck, I have decided just to go back to having my normal password on the login screen and wait for a solution to the double login problem, but apparently I did not bookmark the site I used to remove it and I cannot remember how to undo it..

Any Suggestions?

output of cat /etc/lightdm/lightdm.conf in terminal is [SeatDefaults] autologin-user=

marked as duplicate by Eric Carvalho, Community Jun 6 '15 at 4:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • How did you "remove your login password"? You probably changed setting to login without entering password? – Pilot6 May 26 '15 at 21:34
  • My guess is that you probably set autologin in /etc/lightdm/lightdm.conf file. Open that with sudo gedit /etc/lightdm/lightdm.conf and get rid of lines that say anything about autologin = yourusername (forget the exact syntax). Let us know if that worked – Sergiy Kolodyazhnyy May 26 '15 at 21:38
  • No I tried that first but still received the keyring login prompt so I used the command line to remove my password completely thinking that would work but it still prompts me for my keyring password. so I would like to just try an undo my password removal an go back to logging in twice when I start my computer. I realize this may difficult to answer seeing as how I do not know what command lines used to remove my password prompt but hoped maybe someone might know. – bmweaver52 May 26 '15 at 21:41
  • Nope I do not show anything in lightdm.conf @Serg – bmweaver52 May 26 '15 at 21:49
  • 1
    Well, if you don't figure it out, just create a new account, chown your old folder to your new username and your new usergroup and delete the old account – Sergiy Kolodyazhnyy May 26 '15 at 21:52
1

To get autologin working run in terminal:

sudo gedit /etc/lightdm/lightdm.conf

And in the line

autologin-user=

add your user name.

To disable keyring password you can use THIS GUIDE

But it is a security issue

0

Try using passwd [new passwd] from your account? This will create a password. If that does not work, then sudo passwd -u [new password] [username] definately should.

Not the answer you're looking for? Browse other questions tagged or ask your own question.