5

I installed POV-Ray by running sudo apt-get install povray but now whenever I run:

povray Jmol.pov.ini

I get the error:

povray: cannot open the user configuration file /home/fusion809/.povray/3.7/povray.conf: No such file or directory

Problem with option setting
povray /home/fusion809/Chem Structures/Crystal structures/Jmol.pov.ini
Failed to parse command-line option

where Jmol.pov.ini is the ini file, that is in the same directory as its corresponding pov file, and both were produced by Jmol. I feared that I may have foolishly removed my .povray directory (as the directory doesn't exist at the location specified in this error message) so I reinstalled povray by running:

sudo apt-get install povray --reinstall 

But unfortunately the .povray directory still doesn't exist and I still get the same error.

4

I discovered the solution by running dpkg -L povray which told me where all POV-Ray-associated files were and I found the missing povray.conf file was (/etc/povray/3.7/) so I ran this from the terminal (from my home directory):

ln -s /etc/povray/ .povray

which created a virtual link between the directories so that when POV-Ray went looking in the /home/fusion809/.povray/3.7/ directory it found what it was looking for.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.