8

I updated Chrome to Version 43.0.2357.81 (64-bit) and after restarting Chrome it displays it (Chrome) in low resolution (as far as I can tell). The tabs are bigger, buttons and text the same. Most of all blurry. I see the bug reported here https://code.google.com/p/chromium/issues/detail?can=2&start=0&num=100&q=&colspec=ID%20Pri%20M%20Week%20ReleaseBlock%20Cr%20Status%20Owner%20Summary%20OS%20Modified&groupby=&sort=&id=395425 but almost all solutions are for Windows and those for Ubuntu like "google-chrome --high-dpi-support=1 --force-device-scale-factor=1" do not work for me.

I restarted Chrome, the laptop, switch between the 2 graphic cards I have, changed the screen resolution, the Chrome text size, and pretty much everything I tried had no results.

Any help?

3 Answers 3

5

Bernhard has the right answer, though you would not (necessarily) have to install alacarte to implement. If you are using Dash:

  1. locate google-chrome.desktop in your favorite text editor.
  2. sudoedit /usr/share/applications/google-chrome.desktop (your path may be different, use the path in step #1 for this.
  3. At the end of the first section [Desktop Entry], past all of the Comment[2 character country] lines, replace Exec=/usr/bin/google-chrome-stable %U with Exec=/usr/bin/google-chrome-stable --force-device-scale-factor=1 %U
  4. Save the file
  5. Close all Chrome windows, including the systray and any Chrome apps (Hangouts) you have open

After closing the browser windows, I clicking on the icon in unity launcher and .... voila!

-Hope this helps someone.

3
  • Thanks, I was successful but I want to mention that even after killing Chrome, including don't let Chrome run in background. I had to also kill the Hangouts app as well or the changes wouldn't take. Jun 27, 2015 at 17:18
  • Also worth mentioning is that updates kill this every now and then for some reason. I think this is the case at least. My changes disappeared recently and had to do this a second time. Jul 31, 2015 at 19:12
  • 1
    Thanks man! This helped me so much! Using --force-device-scale-factor with a factor more than 1 it is possible to have bigger UI.
    – Ho1
    Jun 13, 2016 at 9:13
2

Try to launch chromium only with --force-device-scale-factor=1.

I had the same problem and executing it either with both options together, or with the first only made no difference at all. But with the second one alone my eyes stopped bleeding.

4
  • Chromium works though...the issue is with Chrome
    – Tio TROM
    May 26, 2015 at 12:10
  • But if you meant this "google-chrome --force-device-scale-factor=1" is not working either. It opens a new window with the same low quality.
    – Tio TROM
    May 26, 2015 at 12:19
  • Actually, I found the issue with Chromium 43.0.2357.65 as well and I solved as I wrote. May 26, 2015 at 15:43
  • 1
    @user159413 I had the same problem. It occurs when Chrome is still running in Background. If you really exit it before (including the background process) it should work. You can even edit your Chrome App Launcher with alacarte (launchpad.net/ubuntu/+source/alacarte) to always apply the parameter when you run chrome. Jun 10, 2015 at 9:31
1

A temporary fix is to install Chromium and log in with your google account to restore all your extensions and settings and use it until Chrome fixes this issue. It took me 2 minutes to do that so I can continue my work I usually do on Chrome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.