2

I have an oldish net book running 12.04.5 LTS. It works well enough, and I am happy with it.

However, 14.02.2 LTS is out (for a while now), as I am reminded often by the suggestion to do-release-updgrade. Should I do it? My concerns are loss of data and that the upgrade might be more stressful for my little Intel atom powered net book.

My specifications are:

  • 1G Ram
  • 32 bit
  • Intel Atom 2 x 1.66GHz
  • Intel built in graphics
  • how much RAM? 32 or 64 bit? – Tim May 25 '15 at 18:23
  • 2
    I think there is no need to upgrade, if everything works. Support of your system is till '17. Upgrade may go not very smooth. – Pilot6 May 25 '15 at 18:26
  • 1GB isn't enough ram, you need at least 2 and I like to have 4 on my virtual machines. – Tim May 25 '15 at 18:48
2

If it ain't broke, don't fix it.

Upgrading might cause more problems than it'll solve.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.