5

Running Ubuntu 15.10, 64 bit, Desktop, Unity, German keyboard layout, external PS2 keyboard.
I had this problem also on the same machine with 15.04, but not with 14.10, I think (both 32 bit).

After login, NUM-Lock is active and the LED on my keyboard shines. But very soon, it will go off, although the NUM-Lock state did not change, i.e. I can still type numbers on the numpad. But the LED does not match the internal state. It may go off randomly, but usually directly within the first minute(s) after login.

If I hit NUM-Lock now, the LED stays off and the internal state toggles as expected to off as well, so the numpad works as arrow keys now and both LED and real status match. Hitting the key again will turn both LED and NUM-Lock on again, as one would expect it.

Switching TTYs (e.g. to TTY1 and back to TTY7) also "repairs" the inconsistency and the LED shines again, as expected.

Is this random LED/real state mismatch a bug or how can I fix it?

  • Same thing here. Another issue I have is that numlock switches randomly, usually while I'm typing (I'm not hitting numlock key accidentally). At first I noticed something weird was happening when I tried to enter numbers with the keypad, but then I installed the indicator-keylock package and now I can see exactly when it happens. – dschulz Jun 19 '15 at 13:07
  • Did you try another keyboard? – Fabby Nov 26 '15 at 8:31
  • 1
    @Fabby No, but why should it be the fault of the keyboard hardware? It works perfectly on Windows and IIRC it also worked well together with 14.10. – Byte Commander Nov 26 '15 at 11:54
  • @Fabby Just checked, same behaviour on another PS2 keyboard. According to cl-netbox, it also happens on his notebook with internal keyboard as well. – Byte Commander Nov 26 '15 at 13:09
  • @ByteCommander: Thanks for trying: when faced with a weird problem that doesn't make sense, always check the cables and the drivers first! ;-) – Fabby Nov 26 '15 at 18:06
4
+50

This seems to be a little bug - actually appearing in Ubuntu 15.10.
It happens when you start typing too early after booting the computer
(especially when typing the root password ... after being asked to do so).
It also happens when you open an application with root privileges too early.

It does not happen when you wait a few minutes or after the screen turns off when inactive.
As a workaround : either wait some time before starting to type or press the Num key twice.

I decided to file a bug report on Launchpad.

Please may everybody reading this and having observed the same behaviour
confirm this bug to increase its importance and get it fixed quickly! Thank you.

To do this, click the link above, log into your launchpad account and click on:
This bug affects X people. Does this bug affect you? - Select "Yes".

  • Bug commented and confirmed. I'm going to award the bounty in a few days, allowing further reactions. – Byte Commander Nov 26 '15 at 13:59
  • Looks like the bug went away after I installed xubuntu-desktop in parallel to Unity, although I am not using it. See my additional little answer I wrote... – Byte Commander Dec 24 '15 at 15:53
0

I am not sure about this, and it's not really a way to fix it but a hint where the problem might be:

Around the time when I additionally installed xubuntu-desktop, the buggy misbehaviour of the NUM-Lock LED stopped. Probably something that got reconfigured or replaced during that process fixed the problem...

So please, as this is still a bug that must get fixed, go on confirming the bug report @cl-netbox wrote and linked in his answer above. Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.