3

I have a problem with Skype 4.2 during the Test Call that I don't think it matters on client side, but during the test call after the recording and then playback the audio is crackling.

Now I fixed Audacity with the same problem with the package pulseaudio-module-jack and the skipping and crackling in my records was gone afterwards.

I have tried these

high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 5
resample-method = src-sinc-best-quality

But it results in no sound from Pulseaudio on reboot, so I have to comment out the first four and reset the resample-method to speex-float-1.

I did gedit the PULSE_LATENCY_MSEC=60 to PULSE_LATENCY_MSEC=30 and still crackling.

And yes, I have removed tsched=0 from the line load-module module-udev-detect and load-module module-detect and still same thing.

Any help is great at this point.

  • There is a possible fix for your problem found here.bugs.freedesktop.org/show_bug.cgi?id=50510#c4 I am on my mobile now, if it worked, then I will formally post it as an answer later. – daltonfury42 May 25 '15 at 15:42
  • Well, i am going to upgrade PS from 4.0 to 5.0 to see if that will fix it, but I will post results after my shift at work today. – Kyle Morehead May 25 '15 at 15:48
  • Check out my answer. – daltonfury42 May 25 '15 at 15:53
0

Some googling brought this up:

Go into the Skype Options menu - Sound Devices - remove the tick at: Allow Skype to automatically adjust my mixer levels. Click Apply. Readjust the sound mixer controls.

  • Thanks, that fixed it to a acceptable level, I still hear the crackling but now not as bad. – Kyle Morehead May 25 '15 at 21:40
  • @KyleMorehead, if I solved your issue, please mark it as the answer. – daltonfury42 May 29 '15 at 3:04
1

Look like I meet same problem. again.

PULSE_LATENCY_MSEC=60 and tsched=0 won't help.

In google hard and found advice

Seting in /etc/pulse/daemon.conf

resample-method = speex-float-10

Surprisingly solve problem.

Lover quality resampling, like speex-float-8 don't remove crackling complete.


UPD:

Later I found above lover crackling but wont eliminate it completly.

Another cause discussed in Arch wiki related to snd-hda-intel module, in my case ALC887, force me search for snd-hda-intel parameters. And found solution bdl_pos_adj: set IRQ timing workaround for hda-intel

Crackling fixed by applying module parameters in /etc/modprobe.d/sound.conf

options snd_hda_intel vid=8086 pid=1e20 bdl_pos_adj=16,16

  • vid=8086 pid=1e20 is PCI id of my audio device Realtek® ALC887
  • bdl_pos_adj value choosen by experiment
    • bdl_pos_adj=2,2 keep crackling
    • bdl_pos_adj=1,48 make ugly skips
    • bdl_pos_adj=16,16 sounds acceptable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.