0

When a run:

sudo docker ps

in ubuntu snappy i get this error:

FATA[0000] Get http:///var/run/docker.sock/v1.18/containers/json: dial unix /var/run/docker.sock: permission denied. Are you trying to connect to a TLS-enabled daemon without TLS?

Do you know any solution/workaround?

1

I recently found a better solution to the problem, which is to run the command:

sudo aa-clickhook -f

My old solution is below:

I had the same issue. The only thing I found which made it possible to use docker again on snappy core, was to remove and reinstall the docker framework using the commands:

sudo snappy remove docker

followed by

sudo snappy install docker

At that point I was able to run docker commands without incident. I found that my docker images were still available to me, and the ones started with the flag --restart always automatically restarted when the docker framework was reinstalled.

  • I traced this issue to an update of the ubuntu-core which was automatically applied by the system-image client. After the reboot, the new system image was applied, and the docker images started and ran fine, however apparmor seemed to be preventing me from using the unix socket /var/run/docker.sock – Chris Jun 17 '15 at 14:13
  • I found a better solution, which is to regenerate the security policies using the command: sudo aa-clickhook -f – Chris Jun 19 '15 at 23:08
0

You need to create a file called cloud.cfg with the exact lines of text you see below:

#cloud-config
    snappy:
        ssh_enabled: True

save in /home/user/google-cloud folder

and run: sudo ssh -i ~/.ssh/google-ecdsa ubuntu@ <external IP>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.