3

I've recently bought Lenovo z5070, I've installed on it both windows 8.1 and Ubuntu 14.04.2 trusty. I have some serous problem with Wi-Fi in Ubuntu.

First, when I turn on laptop at that moment the Wi-Fi connect correctly but after sometimes if I want to change my access point or if the Wi-Fi be disconnected, the Wi-Fi won't connect again or sometime ask for password and even I enter the password correctly the Wi-Fi won't connect to access point again and I have to restart.

Second problem is that I'm using the access points of university so I need to connect to the VPN server of university to accessing the global internet, VPN connection be disconnected after sometimes and won't connect again.

Third problem and the strangest problem is that when I connected to the access point and I have connection with VPN server, the speed of connection is so low and it's look like that I've not connected to the net.

Model of my wireless card is Realtek RTL8723BE.

The output of wireless diagnostics right after starting my labtop is here

The wireless was connected to the net but it can't receive any data. I disconnect it and connect it again(that was fortunate that it connects again). I ran the wireless diagnostics and the output of it is here

  • Please run the WiFi diagnostics (preferably once shortly after boot and once you experience (re-)connection problems) and edit your question to include a link to the result. – David Foerster May 25 '15 at 8:35
  • I don't know how to attach a file here and when my wireless goes to problem even I can't connect to a wired network. – Mansoor May 25 '15 at 11:52
  • You can store the diagnosis result in a file, reboot, then submit it. Use a pastie service (e. g. pastebin.ubuntu.com) to submit large amounts of text and add a link to the pasted content to your question. – David Foerster May 25 '15 at 12:52
  • You keep editing the question, but did you try to use the given answer yet? – Pilot6 May 25 '15 at 15:45
  • I think the issue is with Realtek wireless card's bug in itself. Most Lenovo users with Realtek RTL8723BE are facing issues with the Wi-Fi connection. There's no support for it either. Tweaks are required to solve the issue. Check the link shared below with similar issues, a possible working solution via command is given there. Try it, maybe it will work for you as well. askubuntu.com/questions/727512/… Good luck! – MIMO Rulz Jan 30 '16 at 12:32
3

You need to install wireless driver. It can be done this way. Run in terminal these commands (one by one):

sudo apt-get install git build-essential
git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo make install

You will need to re-install it after each kernel upgrade.

  • It seems that the wireless work OK for 2 hours. tnx – Mansoor May 25 '15 at 17:35
1

I had the same problem with my Lenovo Z50-75 and the RTL8723BE on windows 8.1. I returned to the shop with all the information from this forum in my backpocket. They opened up my Lenevo and it turned out that the WIFI antenna was not connected to the RTL8723BE, hence poor reception and stuff. They connected it properly and everything worked fine!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.