11

Since I upgraded to Ubuntu 15.04 my system shows a strange behaviour booting: Shortly after the Ubuntu boot splash a form element shows up requiring me to enter an »Auth username«. The boot process stucks, until I would hit enter. What is that, where does it come from, how can I get rid of it?

That's how in looks like:

+------------------------------------------+
|                                          |
|                                          |
|                                          |
|                                          |
|                 Ubuntu°                  |
|                 ....                     |
|                                          |
|                                          |
|                                          |
|           Enter Auth Username            |
|           +------------------+           |
|           |                  |           |
|           +------------------+           |
|                                          |
|                                          |
|                                          |
|                                          |
|                                          |
+------------------------------------------+
  • 1
    Most likely it's from openvpn. Did you define recently any openvpn connection (either directly or using network manager)? – eloy May 26 '15 at 14:56
  • 1
    check your vpn config file. if openvpn: "./build-key-server SERVERNAME" should ask for user and password. – Rinzwind May 26 '15 at 15:00
  • Same problem, and I have an OpenVPN conf. I tried removing the "Shared by all users" on all connections and still no luck... – DReispt May 26 '15 at 21:09
  • @eloy Thank you for the hint, you where right, that it was caused by openvpn. I posted a solution as answer hoping it may help others. – user5950 May 26 '15 at 22:27
  • @DReispt I posted a solution to the problem. – user5950 May 29 '15 at 11:40
10

I encountered this same issue and managed to resolve it. I first opened the OpenVPN init script with:

sudo nano /etc/default/openvpn

And uncommented the line:

AUTOSTART="none"

This should stop all OpenVPN connections on startup and thus resolves the issue without actually removing OpenVPN.

3

The problem was caused by some configurations file in /etc/openvpn. I don't know why the problem came only up after an upgrade to Ubuntu 15.04 as those files had been a long time before there. But actually, if you don't run an openvpn server or have some important openvpn configurations you can easily delete all those files with:

sudo rm -R /etc/openvpn/*

If you want to do a backup first, consider running something like this:

sudo tar -czf /etc/openvpn/
  • 4
    That is not really an option if you need to use openvpn to connect to a company network – Patrick Cornelissen Aug 13 '15 at 6:26
0

I got the prompt at boot time:

> Enter Auth UserName:

I figured out after some time that it is the openvpn server/service starting up (if you try to stop and start the openvpn.service in systemctl, you will get prompted for a password). So, if you only need the client to connect from this current machine to another server, you can disable the service like so (Debian 9, Ubuntu 18.04):

# systemctl disable openvpn.service

Not the answer you're looking for? Browse other questions tagged or ask your own question.