9

When attempting to look at the files on my SD card I get the following message.

## Unable to access “16 GB Volume” ##
Error mounting /dev/mmcblk0p1 at /media/automat0n/6366-3430: Command-line `mount -t "vfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush" "/dev/mmcblk0p1" "/media/automat0n/6366-3430"' exited with non-zero exit status 32: mount: /dev/mmcblk0p1: can't read superblock

The SD card is for my camera and when it's plugged into the camera I'm able to view all it's files and videos so I don't believe the SD is corrupted.

I'm currently running an analysis on testdisk but I'm uncertain what else I can do to get the files off the card. I'd rather not format the card and lose my data.

Any help or suggestions would be greatly appreciated.

  • I'm getting the exact same issue. I think it has to do with -vfat. I was able to get the files off with Testdisk by removing it from etc/fstab/ and finding it there. It seems to work sometimes mounting from nautilus. – waterlubber May 24 '15 at 22:06
  • Check the output of dmesg for more details, but it looks like the card is dead. – psusi May 24 '15 at 22:37
8

Before you try anything else, copy the entire device to a safe place:

sudo dd if=/dev/mmcblk0 of=/var/tmp/safeplace bs=1024k

If dd gives you errors, something may be wrong with your device, or the card reader in your machine. Have you tried reading it on some other machine (I assume the answer is "yes", so read on!)

Next, use try reading the partition table:

sudo parted -l /dev/mmcblk0

What is the partition type?

  1. If it's vfat, maybe the superblock is corrupted; try sudo fsck.vfat /dev/mmcblk0p1 (check the man page for options).

  2. Did you actually create it on a linux machine? If not, maybe it's an exFAT filesystem. Try:

    sudo dd if=/dev/mmcblk0p1 bs=16 count=1 | hd
    

    and see if the first few bytes are 'EXFAT'. If so, install the fuse-based exfat:

    sudo apt-get install exfat-fuse
    

    and try mounting manually if the GUI won't automatically recognize it.

If this still doesn't work, well, we'll have to dig deeper :)

  • 1
    I tried the command you recommended and tried to create an image and dd did infact give me an error dd: error reading ‘/dev/mmcblk0p1’: Input/output error It looks like it might be the card reader on my laptop thank you for the advice! – Automaton May 24 '15 at 23:55
4

In my case, the error was looking like this:

Error mounting /dev/mmcblk0p1 at /media/severin/1885-EB0E:
  Command-line `mount -t "exfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000...

(notice the exfat in the error message)

The fix was simple, like specified here:

sudo apt-get install exfat-fuse exfat-utils

Then, I just clicked the device in Nautilus, and it worked.

  • This worked for me using a microSD card in a USB adapter. The card was formatted for a GoPro, I have a Samsung RC512 running Ubuntu 14.04 – Insperatus Jul 5 '16 at 5:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.