0

I have been having troubles installing g77. When I type "sudo apt-get install g77" in terminal I get:

""" Reading package lists... Done Building dependency tree Reading state information... Done Package g77 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source.

E: Package 'g77' has no installation candidate """

I am aware that g77 is no longer supported. I have gfortran, gcc, etc. installed but I need g77 for some older code that I want to use.

I have read one way to do this is to download g77 (64 bit) and install it (http://conquer-ur-computer.blogspot.ca/2011/02/g77-offline-installation-for-all-ubuntu.html), but I can't seem to find a safe place to download.

Any help would be appreciated.

Thanks.

  • Hi Karel, Yes I read that, but when I searched 'g77' on the Ubuntu Hardy Packages link I couldn't find it. – Canada709 May 24 '15 at 20:55
  • Here it is g77 The download link works, but the file may be crap considering where it comes from is an ordinary filesharing website, so consider installing it in a virtual machine or not installing it at all. The website says crap like Do you know that you can make money with Ziddu?. No, I didn't know that, thanks for sharing. The installation instructions: 1. tar -xzvf g77_x64_debian_and_ubuntu.tar.gz 2. cd g77_x64_debian_and_ubuntu 3. chmod +x ./install.sh 4. ./install.sh – karel May 24 '15 at 21:31
  • Hi Karel. I did as you said and I have now successfully installed g77 (except for step 4 I used sudo install). Before and after unzipping it I scanned for both viruses and malware and found none. Thank you for your help! – Canada709 May 25 '15 at 18:36
  • I'm happy that it worked OK and I apologize about the broken link in the answer that I linked to in my first comment. I won't be posting an answer to this question because if I was writing the same program I would try to make it work with gfortran (GNU Fortran 95 compiler) from the Ubuntu Software Center because I'd rather suffer with gfortran. If you want to answer your own question, feel free to do so, and you can also accept your own answer if you wait for at least 48 hours after the time when you posted the question. – karel May 25 '15 at 18:51
0

To get it to work, I followed karel's instructions:

Downloaded g77 from Ziddu, link on karel's comment. Scanned the file for viruses and malware before and after unzipping it (wasn't sure it Ziddu was safe). Put the unzipped file on my desktop. In the desktop directory of my terminal entered:

tar -xzvf g77_x64_debian_and_ubuntu.tar.gz 
cd g77_x64_debian_and_ubuntu 
chmod +x ./install.sh
sudo ./install.sh

Then it worked (tested by entering g77 in terminal, reads: g77: no input files).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.