I was running Xubuntu 14.04 on a notebook with AMD A8 4500M CPU and dual graphics (HD 7640G + HD 8500M). I chose to upgrade to release 14.10 and then to 15.04, so I wiped the fglrx proprietary driver clean, as recommended, then upgraded.

Now I installed the AMD driver and hardware acceleration packages as described here and everything seems to work fine, except I get this when running vainfo:

error: XDG_RUNTIME_DIR not set in the environment.
libva info: VA-API version 0.37.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so
libva info: Found init function __vaDriverInit_0_32
xvba_video: XVBA_CreateContext(): status 11
libva error: /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so init failed
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

Now I'm wondering if this means hardware acceleration is not working at all, which wouldn't surprise me, given the overall poor performance of this machine with Ubuntu.

Is there something I can do about this?

Update: I did a fresh install of Ubuntu 14.04 w/ open source driver and forgot about about all the fglrx issues :) Now I get slightly better performance and much better battery life.

3 Answers 3


Delete your /etc/X11/xorg.conf

It will make the FGLRX driver to default itself to the HD 7640G after reboot and you'll get working VAAPI with HD 8500M being completely disabled. It seems that "aticonfig --initial" command is unable to generate a proper and valid xorg.conf on a dual-adapter systems regardless of it's additional parameters.

PS You may also need to "apt-get purge" the ubuntu-drivers-common package as it will auto-generate an equally broken and non-functional xorg.conf each time you reboot.

  • Have a virtual beer, you absolute darling! I literally spent days on this since a new install and got nowhere, and now, hey-presto! The tear free option returns! Commented Feb 5, 2016 at 8:48

After a little research it was obvious that xorg.conf doesn't really matter. VAAPI just won't work on a discrete GPU.

aticonfig --px-igpu enables it, while

aticonfig --px-dgpu kills it.


You need to install xvba-va-driver to get it work with fglrx. Run

 sudo apt-get install xvba-va-driver

With this driver discrete GPU will work with vaapi.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .