1

I just installed Ubuntu 14.4 LTS on 32-bit Dell Inspiron 1545 (that was actually pre-packaged with Ubuntu 10.x in about 2010).

For some reason, it doesn't have the capacity to scan for nearby wi-fi network.

I tried adding wi-fi network manually, but Ubuntu still acts as if it doesn't know about wireless

enter image description here

When I try executing:

sudo apt-get install linux-firmware-nonfree

I get error:

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Requested information

sonihal@sonihal-Inspiron-1545:~$ lspci -knn | grep Net -A2
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
    Kernel driver in use: b43-pci-bridge
2

I see that you have a wired connection. Then install the driver this way. But close all programs before that. Like Synaptic or others. Or just reboot. Some program is blocking installation.

Run in terminal

sudo apt-get install bcmwl-kernel-source
sudo modprobe -r b43 bcma
sudo modprobe wl

Wi-Fi should work.

| improve this answer | |
0

I struggled with this.

I completed all of the above, including this post:

Lubuntu Wireless Driver for BCM4309 [14e4:4324] (rev 02)

After installing the bcm drivers my wifi was working - i.e. I could see a list of available SSID's, but just not mine. I tried adding mine manually, but that didn't work, just like above.

My last thought was my router maybe didn't allow ipv6 and that I should disable it on 14.04. But then.. I was about to give up and head back to 12.04 and I came across this post:

http://ubuntuforums.org/showthread.php?t=2214110

Following this, and rebooting (go figure), allowed me to see my SSID and connect.

I am a noob, so please be gentle if it was a bad idea to let people know here. And that thread is closed so I couldn't say thank you to chili555.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.