13

I'm trying to connect an NXT Robot to a windows XP guest in Virtualbox, I have installed virtualbox's Extension Pack. Not a single usb device shows up in virtual box, yet lsusb shows they are all connected to my host.

william@ubuntu-laptop:~$ lsusb
Bus 002 Device 005: ID 0694:0002 Lego Group Mindstorms NXT
Bus 002 Device 004: ID 049f:0051 Compaq Computer Corp. KU-0133 Easy Access Interner Keyboard
Bus 002 Device 003: ID 1c4f:0034 SiGma Micro 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 1bcf:2c18 Sunplus Innovation Technology Inc. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

As you can see, my robot is connected on the first usb, yet nothing shows in Vbox, not even mouse and keyboard, is vbox hiding them by default since they not a storage device? (I have not tried connecting a usb key) I need to way to force Vbox to forward control of the device through the guest, where I can connect it to the RobotC IDE.

I installed Vbox through the software centre. It is version 4.3.26 (Latest, only installed it today)

  • Have you enabled the USB in VirualBox? – Tim May 23 '15 at 9:21
  • Enabled both USB Controller and USB 2.0 (EHUI) Controller. I haven't added any filter, so it should show everything, right? – William Satterthwaite May 23 '15 at 9:23
  • try adding a filter, I find it doesn't show my webcam if it's not exclusive. – Tim May 23 '15 at 9:26
  • I tried adding a filter, still nothing. Tested my theory about only showing storage devices, nope, nothing. Reinstalled extension pack, and I'm getting sick of typing the n word but you get the idea. Maybe I should ask around at the vbox forum as well. – William Satterthwaite May 23 '15 at 9:48
  • 2
    See askubuntu.com/questions/25596/how-to-set-up-usb-for-virtualbox - if all is set up correctly you should see USB devices such as USB keys, printers or the like. Test with these first and report if they failed. – Takkat May 23 '15 at 11:04
20

The proplem was I wasn't part of the vboxuser group. For those with the same problem:

First make sure you have the Virtualbox Extension Pack, this allows use of usb 2.0. usb 3.0 is not yet supported.

Added yourself to the vboxuser group:

sudo usermod -a -G vboxusers <useruame>

Log out then back in for the change to take effect

Enable USB 2.0 (EHCI) controller in the settings for you vm

If you need more help see this topic

Credit to Takkat

0

In my case, after having applied William Satterthwaite's hack above, I could see the list of USB devices in VirtualBox and connect them. But they wouldn't appear in the guest OS. Then I turned off the guest and change the USB adapter from USB 3.0 to USB 2.0. I rebooted the machine and had the USB device displayed in the guest OS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.