0

I had a problem today, when I install the lastest updates, including the headers for linux kernel, tha graphical environment did'nt work, so I've tried upgrade the system, but the terminal even doesn't work, after I restart the system under the kernel 3.19.016 and the graphical environments back to work. The question if anybody knows the solution is how can I repair the kernel problem?, or uninstall the update of kernel 3.19.018? By the way, I'm using ubuntu gnome 15.04............

Thanks.

0

a) boot into recovery mode - preferrably with the old kernel.
b) clean up, i.e remove the new kernel
c) try to ensure that things are ok.
d) reboot

Note that having e.g. Nvidia proprietary drivers may require uninstalling and then reinstalling to make them work again after a kernel update. You might wish to try that first at c), in that case: skip b) and use the new kernel at a)

Easier recovery mode, root prompt: at the recovery mode menu:
1. run the "fsck" option, this will check and then re-mount the filsystems in fstab in r/w mode.
2. enable networking if you need it.
3. drop to root prompt.

4
  • Hi again, it doesn'y work, the system is not able to erase the linux kernel 3.19.018, I don know what to do............ – JESUS0414 May 23 '15 at 17:54
  • does not work, not able to erase the linux kernel are very general descriptions. You must provide very much more detail to allow anyone help you get further. If you cannot provide screen shots in any other way; then use e.g. your smartphone and photograph the screen. – Hannu May 23 '15 at 20:30
  • I get it, however, I can't post photos on this forum because my reputation is very slow, I'm trying to install a new kernel from the session under linux kernel 3.19.016, it sees that works, later I'll tell you how it work and if it's just worked.......... – JESUS0414 May 24 '15 at 6:36
  • Well, I just found the problem, for any reason, the system just update the kernel to ver 3.19.018.18 without a older .17. So, I just installed the previous version and the problem ends, I hope this problem doesn't appears again, thanks so much for you guidance and patience........ – JESUS0414 May 24 '15 at 6:51
0

I suggest booting with a previous kernel using grub. Then upgrade your kernel to 3.16.0-18. There was a critical bug, that was fixed in that version. If that does not help you can use one of previous versions and report a bug to launchpad.

2
  • well, I'm working right now with kernel 3.19.016, however, this computer is for my entire family, so I need a better solution for them, because they don't have the same knowledge That I have, and the kernel stll appears there, How I can to erase it? – JESUS0414 May 22 '15 at 16:57
  • Just upgrade the kernel. Computer will boot always with latest kernel. If you family is not technical, they will never find a way to boot with 3.19.0-16. And also you can find how to remove old kernels here askubuntu.com/questions/2793/… – Pilot6 May 22 '15 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.