1

I'm a linux noob trying to install ubuntu 14.04 to a new 120 gb Kingston SSD. I'm aware there are other questions relating to this but I cannot find anything useful. Apologies if I have overlooked an obvious explanation for this.

Basically, I cannot get any further than the error message "the ext4 file system creation in partition #1 (0,0,0)(sdd) failed" during the installation.

I have a SSD running Windows 7, two 1tb drives for storage and a new ssd i intend to run ubuntu (eventually kxstudio) on.

I followed these instructions on partitioning the drive during the install: http://www.linuxbsdos.com/2012/07/23/dual-boot-ubuntu-12-04-and-windows-7-on-a-computer-with-2-hard-drives/2/

After I got the error the first time, I tried the Erase Disk option rather than the Something Else option, still the same result.

I tried partitioning in Gparted and got the unknown disk label error, and was unable to add a partition table.

I ran the SMART tool in Disk Utility to check the ssd, it was fine.

I then tried to format the disk in the Disk Utility and got the error "Error synchronizing after initial wipe: Timed out waiting for object (udisks-error-quark, 0)"

I have even tried formatting the drive as mbr and then gpt in windows to see if that would do anything, and also turning off uefi options in the bios, still nothing.

So I know i'm a noob to linux but i'm pretty much all out of ideas. Can anyone please tell me what I have done or am doing wrong, and how to fix it? It's doing my head in at this point. I really liked using the live disk and want to use ubuntu as my main OS but I had no idea about these installation dramas.

Could it be a hardware thing? my motherboard is a gigabyte 970a-d3p

Thank you

  • Are you trying to install Ubuntu from a live USB? IS this image broken? May be you should try creating live USB once more if you are indeed using this. – Ron May 26 '15 at 10:33
  • i am booting from a live disc, i have tried with a kxstudio live disc and encountered the exact same errors. this leads me to believe it's not the disc causing the issue. thanks. – Justin F May 27 '15 at 3:31
  • You need to change the IOMMU setting in your UEFI. GIGABYTE GA-970A-DS3 motherboard not working with 64 bit kernel - IOMMU ubuntuforums.org/showthread.php?t=2111223&page=5 [SOLVED] GA-970A-DS3P revision 1 no usb 3.0 ubuntuforums.org/showthread.php?t=2188370 – oldfred Jun 22 '15 at 21:15
0

Try the following:

  • Download Ubuntu's ISO file again AND create the booteable USB again. I had a case with damaged Ubuntu for no apparent reason and it turned out to be an incomplete ISO (with correct file size).

  • Please check your motherboard's BIOS and disable the "Secure Boot" feature. Also, make sure the disk mode is set AHCI (not IDE).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.