9

Since 3 days I'm getting the following error-message, after trying to backup my system using deja-dup:

Your backup appears to be corrupted. You should delete the backup and try again.

There is no information on how this might have happened.

Is there another way to solve this Problem? I'd really like to avoid deleteing my whole record of backups, and start a new one.

  • I assume you are getting this error while trying to restore backup. Not sure if this will work but you can try the suggestion here – Ron May 31 '15 at 7:54
  • 1
    @Ron no, OP says "...after trying to backup my system..." and same thing for me. Routine daily backup starts and then fails with the above error. In my case it was during a 'full' backup and not an incremental one, but I don't know if that matters. – Tom Brossman May 31 '15 at 10:26
  • May be you should try if you can generate any log files using suggestions in answers.launchpad.net/deja-dup/+question/125731 – Ron May 31 '15 at 17:10
  • Does the ~/deja-dup folder exists (or where you stored backups)? – Helio Jun 1 '15 at 17:18
3

Well, I know that this is an old post, but I was just now able to fix this problem for myself, so I thought I will leave a comment here.

When I tried to backup my data today, deja-dup almost completed the backup but finally during verification gave an error, saying that the data is corrupted and backup must be deleted. In retrospect, I remembered that I had a failed network connection while backing-up the last time and may be that could be the source of error.

So here is what I did, and it seems to have worked:

  1. Using Nautilus I navigated to the network location where I backup my data. (File -> connect to server...)
  2. Made the hidden files visible. (View -> show hidden files)
  3. Changed the view to list (View -> List)
  4. Sorted the files based on modification date, latest files first.
  5. Finally I deleted the recent files (today's date + previous date)
  6. Then I tried to backup again and it seemed to have worked.

Just to test it, I deleted few files and tried to restore them, and it has worked fine. A more rigorous test may be required. I will do that later and update my findings.

  • Despite considering that I'm not allowed to say thanks in this comment box, I do say that your solution worked like a charm! Thanks – João Pimentel Ferreira May 8 '16 at 12:28
0

I don't have the means to test this solution out myself, but I read through it and it looks promising: How to recover from a corrupt Deja Dup backup, and set up an alternative. Just make sure you're REALLY careful with typing all the commands (i.e. don't just copy-pasta).

0

Really, unless you need something from a previous backup, you don't need the old backup to do a new backup, and you're probably better off deleting the old backup and doing a new one. As horrible as it seems, that's likely you're best bet. You already can't access your backed up files, so the old backups are useless. Just go ahead and delete and make a new backup. It's not as bad as it may seem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.