1

I am trying to install ckan on my ubuntu 14.04, but i got into some errors that i cant fix, so i decided to do a fresh installation after i remove everything from my computer. I am getting some errors while i try to sudo apt-get remove jetty i get

*Stopping Jetty servlet engine (was reachable on http://myComputer-ubuntu:8983/).

jetty start-stop-daemon: user 'solr' not found

start-stop-daemon: user 'solr' not found

invoke-rc.d: initscript jetty, action "stop" failed.

dpkg: error processing package jetty (--remove): subprocess installed pre-removal script returned error exit status 2

*Starting Jetty servlet engine. jetty start-stop-daemon: user 'solr' not found *(already running). [ OK ]

Errors were encountered while processing:

jetty

E: Sub-process /usr/bin/dpkg returned an error code (1)

after doing sudo apt-get purge --auto-remove jetty I get this error:

The following packages have unmet dependencies:
jetty : Depends: libjetty-java (>= 6.1.26-1ubuntu1.1) but it is not installed

Depends: jsvc but it is not installed

Depends: apache2-utils How on earth can i completely remove Jetty!!??!!

could any one have an idea? Thanks

(also posted on StackOverflow, but this seems like the proper place for it)

2

You just edit the jetty startup script /etc/init.d/jetty I assume, and put a clean exit on the 2nd line:

#!/bin/sh -e
exit 0

then

apt-get update && apt-get -f install

And that will cleanly remove jetty. it fails because the init script fails.

0

I have been experiencing the same error messages on Ubuntu 14 and I've just figured out what it was.

The issue was with the line endings of /etc/default/jetty. It turned out that the file had been edited on Windows and had line endings of CRLF, once I updated the file to LF and re-ran it the issue was solved.

The quickest way to test this is to revert back to Jetty's original config by running sudo mv /etc/default/jetty /tmp/ and then run sudo service jetty restart. If you have the same issue as me, jetty will restart properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.