0

I created a bootable USB of Ubuntu 14.04 and 15.04, via unetbootin, on OS X. The USB live session seems to work in principle, tested it on the Mac I created it on, and can get into a Ubuntu live session (both with 14.04. and 15.04)

The problem:

Trying to get a live session working on my old Thinkpad SL510 (on which I want to install Ubuntu from that session) fails. This is surprising because previously, it worked flawlessly, and in fact, an old version of Ubuntu is installed on the Thinkpad.

Perhaps this is actually related: earlier today, I tried to upgrade the old Ubuntu version on the Thinkpad with apt-get dist-upgrade. Several errors happened during the upgrade (the Ubuntu version was badly outdated, I should add), so I decided to simply re-install via USB. But, as it turns out, that doesn't seem to work anymore.

Timeline of the error:

Thinkpad starts up. Option to go to BIOS. Changed boot order to have USB drive on top. In addition, I can also select which drive to boot from via F12, and can select the USB as bootable drive.

After selecting the USB with Ubuntu on it, there is a split second of waiting time, then no activity whatsoever, except for a black screen with a blinking cursor in the top left corner.

To summarize:

  • Ubuntu Live USB not working on Thinkpad SL510, despite Ubuntu working on the machine previously.
  • Problem doesn't seem to be related to boot order (since I can select the USB as boot drive directly), but perhaps to some screw-up during previous distro upgrade of badly outdated Ubuntu on the Thinkpad.

Any ideas what's the problem?

Any chance that it's grub related? But if so, wouldn't the option to boot from USB appear anyway, and the boot problem only appear after installation to HDD?

Or maybe related to not finding a graphics display (maybe some driver got screwed up during the failed upgrade?) If so, I guess Ubuntu boot option nomodeset might be worth trying, but unfortunately, I don't know how I could even set it, since I never get to the Ubuntu Live Session menu.

  • Does your thinkpad have another OS on it – Find Me In The Woods May 21 '15 at 18:36
  • Yes. Forgot to mention, dual boot with Windows 7. Without the USB, I can select Win7 at startup and it boots. Selecting at startup (also without USB) the old probably broken Ubuntu installation doesn't work, yields black screen. – zanglebert May 21 '15 at 18:46
  • Okay, looks like it's working again. Will write up the fix I found as an answer. Sorry if I wasted your time. – zanglebert May 21 '15 at 18:58
2

So, at first I was thinking it's most likely a problem with some BIOS startup settings, since that seems to be the most common problem in cases like mine, but as it turns out, that wasn't it.

Now I found a solution myself, described below. I still don't know why it works, but here's the how...

The problem seems to be that I initially created the bootable USB with UNetbootin.

Instead of using UNetbootin to create the bootable USB, I now tried the manual creation of a bootable Ubuntu USB, as described here or here (under: dd image of iso file), and it works now, both on the Thinkpad (and the Macbook).

If anyone else has an idea why the above makes the difference, please write it as an answer in here and I will mark your answer as 'solution' (unless that's against stack etiquette).

  • For the why part, I think Ubuntu usb creation has been changed in newer versions and unetbootin was doing the old way, that is extracting iso and installing syslinux on usb, which won't work anymore. – Anwar Nov 5 '17 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.