32

I have installed Ubuntu alongside Windows 8.1. But the wifi is not working in Ubuntu (perhaps the drivers are not present), which worked fine in windows. Also I cant connect with Ethernet since my laptop does not have an Ethernet port. So is there any way for me to connect to the internet in ubuntu?
Edit: Output of the terminal command lspci -knn | grep Net -A2:

vikram@vikram-Inspiron-11-3148:~$ lspci -knn | grep Net -A2
01:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: Dell Device [1028:0018]
    Kernel driver in use: bcma-pci-bridge
vikram@vikram-Inspiron-11-3148:~$ 

I did what Pilot6 suggested. Here is the output:

vikram@vikram-Inspiron-11-3148:~$ sudo dpkg -i *.deb
[sudo] password for vikram: 
Selecting previously unselected package bcmwl-kernel-source.
(Reading database ... 163804 files and directories currently installed.)
Preparing to unpack bcmwl-kernel-source_6.30.223.141+bdcom-0ubuntu2_amd64.deb ...
Unpacking bcmwl-kernel-source (6.30.223.141+bdcom-0ubuntu2) ...
Selecting previously unselected package dkms.
Preparing to unpack dkms_2.2.0.3-1.1ubuntu5.14.04_all.deb ...
Unpacking dkms (2.2.0.3-1.1ubuntu5.14.04) ...
Setting up dkms (2.2.0.3-1.1ubuntu5.14.04) ...
Setting up bcmwl-kernel-source (6.30.223.141+bdcom-0ubuntu2) ...
Loading new bcmwl-6.30.223.141+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 3.16.0-30-generic
Building for architecture x86_64
Building initial module for 3.16.0-30-generic
ERROR (dkms apport): kernel package linux-headers-3.16.0-30-generic is not supported
Error! Bad return status for module build on kernel: 3.16.0-30-generic (x86_64)
Consult /var/lib/dkms/bcmwl/6.30.223.141+bdcom/build/make.log for more information.
modprobe: FATAL: Module wl not found.
update-initramfs: deferring update (trigger activated)
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
update-initramfs: Generating /boot/initrd.img-3.16.0-30-generic
vikram@vikram-Inspiron-11-3148:~$ 
5
  • What about using a USB modem? May 21, 2015 at 16:58
  • 1
    Please edit your question and add output of "lspci -knn | grep Net -A2" terminal command.
    – Pilot6
    May 21, 2015 at 16:59
  • @ln78 Please Edit Your title and add more info. May 21, 2015 at 17:02
  • I updated the answer. They install new kernel, but old driver.
    – Pilot6
    May 21, 2015 at 18:01
  • Possible duplicate of Installing "fimware-b43-installer" offline
    – Woeitg
    Feb 10, 2016 at 10:26

2 Answers 2

43

You need to install wireless driver.

Insert your Ubuntu installation disk or a flash drive and copy these files from the installation disk to your Home directory:

pool/main/d/dkms/dkms_XXXXX.deb
pool/restricted/b/bcmwl/bcmwl-kernel-source_XXXXX.deb

Then run the following in terminal:

sudo dpkg -i *.deb

If you have UEFI BIOS, you need to disable Secure Boot to load the driver.

18.04 update:

The solution won't work on 18.04, because build-essential and its dependencies are not installed by default. The dpkg command will complain that dependencies are not installed.

You can manually find the required packages on the installation media ("pool" directory sorted by alphabet) and install them the same way as the dkms package. I hope nothing is missing there.

9
  • The second link is not working,can you please look into it and give an alternate place to download Oct 25, 2015 at 5:37
  • I updated the link. But it will be changed from time to time.
    – Pilot6
    Oct 25, 2015 at 10:00
  • I have just used this advice for Xubuntu 16.04 and installing the driver was no problem. I guess they have fixed the problem from 14.04.2. Jul 28, 2016 at 14:13
  • 1
    I have dowloaded both the Standard and Alternate installers. Don't see them. Only main and universe folders under pool. No restricted. No dkms in d folder. I see djvulibre and dmidecode.
    – sureshvv
    Jul 13, 2018 at 22:24
  • 1
    askubuntu.com/questions/730799/… worked best
    – sureshvv
    Jul 14, 2018 at 5:53
1

I recently needed to install the Wifi firmware for an older repurposed iMac 9,1. It had Broadcom 4322 Wifi, and Nvidia Ethernet, neither worked with 20.04. It found the card and tried the correct module (b43) but complained via dmesg "firmware not found."

The following steps I found online worked:

  • Find the broadcom firmware on another machine:

  • Install ./pool/main/b43-fwcutter*.deb manually from Ubuntu Disc/Flash drive.

  • Run the following:

    • sudo b43-fwcutter -w /lib/firmware broadcom-wl-*.o # write to /lib
    • sync
    • sudo modprobe -r b43 # remove
    • sudo modprobe b43 # reload

With that Network manager noticed and started up Wifi. :-D

To automate the firmware update, this can be done now that the network is up:

  • Enable multiverse in software-properties-gtk or apt/sources
  • sudo apt-get install firmware-b43-installer

Not the answer you're looking for? Browse other questions tagged or ask your own question.