11

After upgrade to 15.04 my ubuntu loads really slowly, slower than Windows 8 on the same machine, which insults me.

I turned off splash screen, and when I boot the system I get this:

A start job is running for dev-hdb2.device

and It stays that way for 1:30 minute, with a time counter next to it set exactly to 1:30.

Also when I reboot I get this message:

A stop job is running for Session c2 of user MrMino

same here - it stays that way for 1:30

Output of dmesg: http://pastebin.com/yzbFQG05

Unfortunately bootchart isn't working for some reason not known to me now, so I can't post logs from it.

How to make this go away? I'm running ubuntu on Dell Inspiron 3537.

1

I managed to fix this by rolling back from systemd to upstart. More info here:

https://wiki.ubuntu.com/SystemdForUpstartUsers

Permanent switch back to upstart
Install the upstart-sysv package, which will remove ubuntu-standard 
and systemd-sysv (but should not remove anything else -- if it does, yell!), 
and run sudo update-initramfs -u. After that, grub's "Advanced options" 
menu will have a corresponding "Ubuntu, with Linux ... (systemd)" 
entry where you can do an one-time boot with systemd.

If you want to switch back to systemd, install the systemd-sysv and ubuntu-standard packages.
1

I had the same problem in my Manjaro, searching I found a post in a reddit forum of Arch Linux.

Here is the solution that works for me https://www.reddit.com/r/archlinux/comments/4bawf7/a_stop_job_is_running_for_session_c2_of_user/d17th3u

You need to ubuntulize it:

Install watchdog

# pacman -S watchdog

And then start the service at boot:

# systemctl enable watchdog.service

Start the service to don't see the message any more

# systemctl start watchdog.service

I create a gist for this https://gist.github.com/dianjuar/98d02af4050dc2df8ae6f18695d44ca3

  • Hey, it's nice that someone finally answered this. I would love to check if it works, but I'm now running Ubuntu Gnome, and it has no problem with this. +1 For the gist though. – Błażej Michalik May 20 '16 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.