2

I installed Play On Linux, because I want to install World of Tanks game. But when this game installation process starts appears this error which is in print screen. What should I do in this situation?

  • 1
    Can you provide the version of PlayOnLinux and Wine? – Paulius Šukys May 20 '15 at 14:41
  • And what error it does – Wilf Nov 20 '15 at 19:42
1

This problem is easy to fix. Its the torrent client in world of tanks that crashes. When the program crashes, leave it be !

open a file browser and go to "your home folder" + .PlayOnLinux/wineprefix/WorldOfTanks/drive_c/Games/World_of_Tanks/Updates

mine full path: /home/kabman/.PlayOnLinux/wineprefix/WorldOfTanks/drive_c/Games/World_of_Tanks/Updates

hit: ctrl+h in filebrowser on Ubuntu to see hidden files.

Start the torrentfile in that folder and download it with your favorite torrent downloader then place the downloaded file in that directory.

Then go to the world of tanks program and hit ok to restart it. Then World of tanks will extract the file and install as normal :)

you probably have to do this a couple of times for the different torrent files :(

the up to date files in my update directory now is:

wot_9C.465_launcher.patch      wot_9C.7159_sdcontent.patch.torrent          wot_9C.7160_client.patch             wot_9C.7168_9C.7160_client.patch
wot_9C.634807_locale_en.patch  wot_9C.7160_9C.7159_sdcontent.patch          wot_9C.7160_client.patch.torrent     wot_9C.7207_9C.7168_client.patch
wot_9C.7159_sdcontent.patch    wot_9C.7160_9C.7159_sdcontent.patch.torrent  wot_9C.7161_9C.7160_sdcontent.patch
  • When I last tried this,u ou can disable tit torrents from the WoT GUI using the settings button to the top right, but you had to do it quick before it crashed - then it would download the files directly (which would be slower on most networks). See also: appdb.winehq.org/… , you may want to suggest fixes there. – Wilf Nov 20 '15 at 19:46
1

Open wotlauncher.cfg with gedit and change number 3 in this line with number 2

<launcher_transport>3</launcher_transport>

and then it downloads via HTTP. Check wineHQ for other problems.

  • File is here /home/[user]/PlayOnLinux's virtual drives/WorldOfTanks/drive_c/Games/World_of_Tanks/Updates/WoTLauncher.cfg. Worked for me. – parsley72 Apr 25 '16 at 15:07
0

I've seen that many times with the Windows program continuing to run, but it's also a very generic, no-help failure message from PlayOnLinux, saying the Wine it started has crashed -- and nothing more. The most useful thing I've found to deal with this error is to experiment with different versions of Wine in the POL installation for your Windows program; the three Windows games I use at all frequently work best with three different Wine versions. You might also check the Wine AppDB to see what rating World of Tanks has, and what if any Winetricks are recommended for running it (most of which can be emulated with built-in POL features like "install DLL").

0

Maybe it will help someone.

I got problem with downloading file msls31.

https://www.playonlinux.com/pl/app-522.html

My solution:

let the installer crash, click cancel.

open up /home/ -your user name-/.PlayOnLinux/tmp

for example /home/Jkowal/.PlayOnLinux/tmp

edit file called POL_Install_msls31

by removing everything and paste following:

#!/bin/bash # PlayOnLinux Function # Date : (2009-11-19 21-50) # Last revision : (2016-10-13 20:05)# Author : Berillions # Updated by : l.ukasz # Licence : # Depend : none POL_Wine_WaitBefore "msls31" # Official link don't work now, using archived file from Internet Archive WayBack Machine POL_Download_Resource "https://web.archive.org/web/20160710055851/http://download.microsoft.com/download/WindowsInstaller/Install/2.0/NT45/EN-US/InstMsiW.exe" "53820efbc952107ee1a38be6cd5aa3f0" # POL_Download_Resource "http://download.microsoft.com/download/WindowsInstaller/Install/2.0/NT45/EN-US/InstMsiW.exe" "53820efbc952107ee1a38be6cd5aa3f0" cd "$WINEPREFIX/drive_c/windows/system32" cabextract -F msls31.dll "$POL_USER_ROOT/ressources/InstMsiW.exe"

then: 1. right click on the file that you just edited 2. choose properties 3. go to Permissions label 4. set Access as read-only 5. try to install 6. accept script from unknown source It worked for me :)

0

I have try playonlinux too, but it fails. There are another solution:

PortWoT - http://portwine-linux.ru/world-of-tanks-linux/

WoT have gold status in wine db, but I had unable to install it, launcher crashes. Port WoT is a solution. It keep updated for years and work fine.

PortWoT - is the port for the client World Of Tanks 1.x (SD and HD customers) under Linux through WINE . With a convenient and simple graphical installer, maximum performance and native WoTtweaker `th.

Here are full explanation in my answer: Will "World Of Tanks" run on Ubuntu?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.