2

I reset my login in password on two desktop computers using the GUI at System Settings > User Accounts.

One computer gave no grief whatsoever, but the other computer the one I use as primary turned in to a nightmare.

Had to go to reset the login password using the CD. Finally got back into that computer.

BUT, I kept getting a pop up unlock login keyring on boot and when starting Chrome.

I found a solution for resetting the keyring using the terminal:

rm ~/.local/share/keyrings -fr

The unlock login keyring pop up went away on boot.

BUT, when I open Chrome I still get the pop up every single time.

Although I cancel the unlock login keyring when Chrome opens all the sign ons still work in Chrome, so it seems unnecessary.

I discovered that there is a program called Passwords and Keys, within which I tried to change the Login > Passwords.

In the pop up Enter the old password for login keyring, whether I put in the old or new login password I keep getting

The original password was incorrect

The computer that is giving me grief came with 13.10, I used a CD to set the OS to 12.04 LTS right after I got the computer in December 2013. Upgraded using a CD to 14.04 LTS a year ago ~ May 2014.

The old password I changed has been the password since the computer was new.

Absolutely have to have a login password.

  • When did you last wipe it, it sounds like a bad install carried over from 13.10. – Virusboy May 20 '15 at 13:31
  • Additionally askubuntu.com/questions/867/… – Virusboy May 20 '15 at 13:32
  • wiped the computer that been giving me the problem. I soon not. Since I put a lot of Libraries some are “silent” dependencies and are real pain to make sure everything working correctly. I wiped the other computer when put in the update to 14.04 LTS still got work to do with the libraries and assorted setting and what not. I flat do not have the time to do that. – mark_97 May 20 '15 at 21:12
  • I rechecked the post that you referenced. Same situation. Put in the old or new login password keep getting “The original password was incorrect”. – mark_97 May 20 '15 at 21:12
  • I was hoping to be able to set the login password for Passwords and Keys with the terminal. I not sure the exact name of the program for Passwords and Keys. If that program lacks a provision to force the password change then I might be able to remove it and reinstall it. – mark_97 May 20 '15 at 21:12
2

Reran

rm ~/.local/share/keyrings -fr 

unlock login keyring on boot went away!

Chrome:

Signed out of Google accounts in Chrome.

Dumped / cleared history in Chrome, checked all the boxes in the history pop up.

Shut down Chrome.

Open Chrome.

Sign in to Google accounts, check that all Google “services” work correctly.

Shut down Chrome.

Open chrome.

No unlock login keyring when I start Chrome!

Appears that chrome was “hooked” somehow to the old password. Flushing the save passwords fixed the popup somehow.

0

I just had the same error on 14.04 and it turned out to be a two-iterations-retired password, that had been the original login and LUKS password on the install.

So trying very old passwords can help.

I've asked another question to try to understand why and what to do about it at

Just in case that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.